Autorun of Startup Organizer

Author Message
Jose Nunes 06/06/2010 06:15 am
Hello

Since I installed Windows 7, Startup Organizer 2.9 doesn't start-up although it is configured to do so. Is W7 preventing it ?
Anton 07/19/2010 04:53 am
I have same problem.
Check box "Start with Windows" is on.

Please answer!
Oleg Chernavin 07/24/2010 10:06 am
Thank you for reporting it! I just fixed the error. Please test it and let me know how it works now:

http://www.metaproducts.com/download/betas/sosetup.exe

Best regards,
Oleg Chernavin
MP Staff
Ron 09/01/2010 09:50 pm
I noticed this too months ago. I solved it by using Task Scheduler to start SO. Seems this is essential because SO needs to run elevated to recognize some registry entries in 64-bit windows.

It seems as though the programs that SO starts up do not run elevated - which is a good thing in most cases. But if I run (right click - run) from withing SO, programs do start elevated because SO is running elevated. My guess is that during boot, ctrl.exe somehow manages the startup programs and even though SO is started elevated, the programs it executes on boot (via ctrl.exe?) do not start elevated.

Maybe a future update will simplify this?
Oleg Chernavin 09/02/2010 12:18 pm
Please test the new version:

http://www.metaproducts.com/download/betas/sosetup.exe

Would it work correctly now?

Oleg.
Ron 09/23/2010 12:03 am
No. SO shows in msconfig and in SO as one of the programs that will run on startup - but it doesn't.

Maybe it starts then exits? How else could you explain ctrl being invoked???

I don't mind starting it via Task Scheduler. That avoids me having to answer the "do you want to allow" prompt when it's started.

So having it not run - or stay running - on startup is not an issue for me. Ctrl.exe is important and it somehow starts and runs all my controlled items as normal - not admin. Further discussion of that in my other post.
Oleg Chernavin 09/23/2010 01:20 pm
It is strange. It can start and minimize to tray, but I am sure you would notice it in the tray. I will continue looking to reproduce this.

Oleg.
Ron 09/23/2010 08:28 pm
I'll verify this too. I did look in the tray because I too have it set to minimize on start. I didn't think to look at task manager. On occasion an app might be running but not be shown in the tray.
Ron 09/23/2010 09:57 pm
Problem confirmed on Win7 Pro x64.

Installed SO, verified it was set to...

run in system tray
minimize on start
X button minimizes the main window

Rebooted. SO is not in task manager nor in the system tray. But msconfig shows an 'enabled' entry for it. How is this possible?



Oleg Chernavin 09/24/2010 06:49 am
Could it be related with the admin mode requested to start SO? Maybe there is the requested screen that needs to be confirmed?

Oleg.
Ron 09/24/2010 11:11 pm
I don't think so. No prompt ever appears offering me the chance to give it permision to run as admin.

Ron 09/24/2010 11:47 pm
Ok. Despite being set to run on start-up, confirmed by msconfig and SO displays of start-up programs, it just will not even attempt to run. Sortof - read the last paragraph.

SO. I moved SO to controlled start-up. When I booted and logged in I got the permissions dialog for SO, answered yes, and it loaded!

Weird. So the workaround is to place in in controlled start-up. BUT, I will not do this because I don't want to deal with the permissions prompt. Windows 7 Task Scheduler is still the easiest way to run SO as admin on start-up with no prompts.

Does Startup Organizer invoke CTRL.EXE? I'm thinking is must. If true, then SO must be running on start-up, at least just enough to invoke CTRL before exiting. I even turned off run at start-up and the controlled start-up items still get processed. I associated a sound with controlled start-up items and I can hear that sound even with SO Load at Start-up NOT checked. I'm thinking now that SO must run twice. Once as normal to invoke CTRL, then again as admin to begin monitoring the system. But as I stated above, this second launch doesn't take place unless SO is in the controlled start-up section. Last but not least, when it is started after being placed in the controlled start-up section - it runs as admin. That's contrary to CTRL's behavior. All of the programs started by CTRL run as a normal user. But not in this particular case. Of course that's not a problem because you want SO to run as admin. I just can't explain why it does when CTRL apparently launched it!
Oleg Chernavin 09/27/2010 08:53 am
No, ctrl.exe is started by the system, not by Startup Organizer. This is why it gets non-admin preferences and all the app that are launched by ctrl.exe.

SO.exe always starts as admin - no matter how it gets started. This is because it contains "manifest" that tells the system that it should be run as admin.

Oleg.
Ron 09/27/2010 08:56 pm
Ok, another thing I never did was to check the box that displays ctrl.exe in "the list". Now I understand how it gets started.

So the only weirdness remaining is why SO will not start when msconfig indicates that is will be run. Apparently on your system is DOES start?

Still, not an issue for me because Task Scheduler is the best way (currently) to start it - without any prompts to grant permission.
Oleg Chernavin 09/28/2010 06:42 am
Yes, it starts here and on several other very different systems. I will continue testing to find any other similar issue.

Oleg.
Ron 10/01/2010 11:40 pm
FYI, I tested it on a non-VM Win7 Enterprise box the other day I was setting up for the office. It does start when I log in to that system.

I'm not going to spend any more time on this particular issue though because I use Task Scheduler to start it elevated which avoids the permissions prompt.
Oleg Chernavin 10/02/2010 07:06 am
Yes, I see.

Oleg.