Services questions

Author Message
Mike Kerr 10/25/2004 12:08 pm
When backing up configurations with SO, does SO save the startup type for services ?

I`m running SO 2.5.222. I saved my configuration and then disabled a service (previously set to
automatic). Later on, I did a restore from the saved config and expected the service to return to
its automatic setting, but it remained disabled.

Also, if I disable a service and then reboot, windows tells me that the service isn`t running (as
expected). Under the services tab of SO, the service isn`t running. However, under the All Programs
tab, the service is shown as enabled and running ? Is this correct ?
Thanks.
Oleg Chernavin 10/25/2004 12:17 pm
Startup Organizer does not backup services, because it may lead to a serious failure if a certain service was not properly stopped or started.

However we plan to work on a new method that will make sure that backup/restore of services works smoothly.

The All Programs tab doesn`t show services. It shows only the autostarted programs. Perhaps, some program was registered itself as a service and it also runs as a program when you start your system. Anyway, they are separate.

Best regards,
Oleg Chernavin
MP Staff
Mike Kerr 10/25/2004 12:24 pm
Thanks for the rapid response !!!

Also, I`ve just realized that what I`m seeing under the All Programs tab is in fact a help program
for the service. What confused me was that the name is the same as the service, but its a different
executable. Makes sense now.
Oleg Chernavin 10/25/2004 12:36 pm
Yes, it is so. You are welcome!

Oleg.