Downloading a specific website

Author Message
Bruno 02/28/2006 08:01 pm
Hi.

I`m trying to download http://usemycomputer.com/indeximages/women/Lindsay.Lohan/index.html but I can`t download the full images because the thumbnails link to, for example, http://www.usemycomputer.com/show.html?image=/indeximages/women/Lindsay.Lohan/12.jpg. So, I don`t want OE to download everything in http://www.usemycomputer.com, but only http://www.usemycomputer.com/show.html?image=/indeximages/women/Lindsay.Lohan/12.jpg. My problem is with that show.html thing. Do you know how can I bypass that?
Oleg Chernavin 03/01/2006 04:33 am
I think, you need to allow downloading only:

index_*.html
show.html

files using the URL Filters - Filename section - Custom Configuration. It is in the Project Properties dialog.

Best regards,
Oleg Chernavin
MP Staff
Bruno 03/01/2006 02:59 pm
But doesn`t that mean that OE will download only index_*.html and show.html? I tried that and it didn`t work...I want to download the whole Lindsay.Lohan directory, including the full pictures.

Thanks!
Bruno 03/01/2006 03:02 pm
I tried to browse the downloaded website. When I click a thumbnail, I get "Query Variable image not found" and "Stack overflow at line: 0". The pages shows up but with a broken image...
Oleg Chernavin 03/01/2006 03:03 pm
OK. Allow:

show.html
http://usemycomputer.com/indeximages/women/Lindsay.Lohan/*

In the same section. This should work.

Oleg.
Bruno 03/01/2006 04:10 pm
Hi,

That doesn`t work either...more details:

Addresses: http://usemycomputer.com/indeximages/women/Lindsay.Lohan/index.html
- Load files only from the starting server
- Load files only from the starting directory and below
Bruno 03/01/2006 04:24 pm
I restarted the project, and OE didn`t download show.html now, probably because it`s in the root directory (http://www.usemycomputer.com/), and in my directory config I have "Load only from the starting directory and below"...
Oleg Chernavin 03/02/2006 02:34 am
Yes, you need to allow all directories. URL Filters - Filename will not allow Offline Explorer to get too much.

Oleg.
Bruno 03/02/2006 09:11 am
Now it downloads show.html but when I click a thumbnail, the page shows up but no image ("Error Loading Image" instead) and an error: "Query Variable image not found".
Oleg Chernavin 03/02/2006 11:23 am
Yes, the script cannot properly work offline. OK. Here is another solution. Please use the Project I published in the Photo Albums section (Tools - Published Projects).

Oleg.
Bruno 03/03/2006 09:43 am
That didn`t work either :(

I don`t have much time now, but this weekend I`ll try setting http://usemycomputer.com as the starting URL, and then exclude all the directories except /indeximages/women/Lindsay.Lohan/. Maybe that will work...

Thanks for your attention!
Oleg Chernavin 03/04/2006 10:43 am
Excluding directories will not help either, because the script will still not allow you to load images. Can you please tell me, what is wrong with my Project?

Oleg.
Bruno 03/04/2006 11:10 am
Oh, ok!

The project you put there still doesn`t download the images, and show.html isn`t downloaded too...
Oleg Chernavin 03/06/2006 05:54 am
I updated the Project there - please try to get it again.

Oleg.
Bruno 03/06/2006 08:38 am
Works even better than the actual website, cause there`s no show.html, only the image loads!

Thanks you very much for the attention and congrats for the great program!
Oleg Chernavin 03/06/2006 09:35 am
Great that it helped you!

Oleg.
Zac 04/19/2006 01:34 am
I've had problems with this exact thing and I started seraching for new programs. I came accross this site. I downloaded the trial and attempted to download the LL site with the link you posted. It won't work for me. I just get an error:
---------------------
Document not found
This page is not accessible offline. Possible reasons: either it was an invalid link on the server or Project settings do not allow the page to be downloaded. In some cases, increasing Project Level setting should help.


Click here to go online:
http://usemycomputer.com/show.html?w=895&h=511&i=/indeximages/women/Lindsay.Lohan/04113216.jpg

Download the missing link now and add it to the selected Project.

----------------------

What's up with that?


Oleg Chernavin 04/21/2006 08:24 am
Can you please tell me the URL of the page with these links? I will see what should be done to allow these links to be loaded.

Best regards,
Oleg Chernavin
MP Staff
Zac 04/25/2006 03:42 am
> Can you please tell me the URL of the page with these links? I will see what should be done to allow these links to be loaded.
>
> Best regards,
> Oleg Chernavin
> MP Staff


http://usemycomputer.com/indeximages/women/Lindsay.Lohan/
Zac 04/25/2006 04:11 am
Ok, this program is gettting kind of glithy. Any page that is viewed in the internal browser comes up with 3 or more debug messages on every refresh.

Anyways, to make this simpler, use the URL:
http://usemycomputer.com/indeximages/women/Abi.Titmuss/

there are very few pictures in it. Whenever I go there, there is no index.html, so idon't know the location of the actual address. I tried using the project you made for the other guy, and it just downloaded thumbnails. I want to be able to click the thumbnails and goto the actual pictures like you can on the website. Is this even possible? Why is it so complicated to get it to do this?
Oleg Chernavin 04/25/2006 07:18 am
I just published an improved template for this site.

Oleg.
Zac 04/25/2006 06:55 pm
Amazing, I'm deffinately buying this when my trial runs up!

By the way, what was wrong in the settings?

Zac
Oleg Chernavin 04/26/2006 04:46 am
I changed the URL Substitutes rules to work with more links on that site.

Oleg.
Kurt 01/12/2007 01:30 pm
> I changed the URL Substitutes rules to work with more links on that site.
>
> Oleg.

My company purchased your Offline Explorer 4.5 product and I do not see the URL Substitutes option available. I right click on a project, go to properties, look in the advanced section and I see no URL Substitute section. Is there something I'm missing here?

As I was running through some testing I tried to download the following section of the www.ufl.edu website. Due to the page type being hidden I'm not sure how I rip a site similar to this one. I tried changing different options and if I could find the URL Substitutes section I'm sure I may be able to figure it out, but I do not see that section as I stated above. Any help will be much appreciated.

Here is the URL to the starting page of what I was trying to download:
http://news.ufl.edu/2007/01/10/bcs-postgame/
Oleg Chernavin 01/13/2007 10:50 am
URL Substitutes feature is in the Offline Explorer Pro and Enterprise editions.

Regarding this particular site - you don't need this feature to load it. Simply allow all directories to be loaded and use Level=1 or more. If you need only 2007 news, then use Properties - URL Filters - Directory to enable only /2007/

Oleg.
Kurt 02/09/2007 09:12 am
When I attempted to download the 2007 section the way you stated above I still ran into the following problem. When I view the downloaded copy of http://news.ufl.edu/2007/01/10/bcs-postgame/ locally on my computer and clicked the images links (on the right side of the page) I received a 404 error. Those pages did not download because Offline Explorer attempted to append default.htm to the end of the folder directory specified in the hyperlink. Notice if you go to http://news.ufl.edu/image/387/default.htm you get a 404 error, but if you go to http://news.ufl.edu/image/387/ the image page displays. Is there any way to make sure offline explorer grabs the content of these pages when you download the 2007 section of the site?
Oleg Chernavin 02/12/2007 10:33 am
OK. Enable loading these folders as well. Offline Explorer has to add default.htm, because it is impossible to create files with an empty name on your hard disk.

Oleg.
Bobby 03/13/2007 05:15 pm
Dear Olga,

We are testing a few Offline Explorer products for a new research projects in my company.

We experiment the following problems with your product:

With sites that have PHP extensions not all the links and files on the webpage and subdirectories were downloaded.
It shows also showpic?showme=”35641”, but it does not download the actual Image (jpg).
When I click on it (in browser) it asks me to “Download the missing link”,.
However, the are many hundreds files,
We tried a different higher “Level Limit” but the results were a lot of unrelated pages.

Please let me know if there is any way to correct this issues.

Best regards and thanks
Bobby


> I think, you need to allow downloading only:
>
> index_*.html
> show.html
>
> files using the URL Filters - Filename section - Custom Configuration. It is in the Project Properties dialog.
>
> Best regards,
> Oleg Chernavin
> MP Staff
Oleg Chernavin 03/14/2007 06:53 am
Please try to allow script calculations in the Project Properties dialog - Advanced section. If this doesn't help, you may contact us at support@metaproducts.com with more details and we will help you.

Oleg.
haribo12 04/16/2008 09:17 am
No, it does not work for me.
I am trying to save the changes of these sites, but it doesn't save anything at all.

http://www.peppermintfm.de/playlist.php
http://www.defjay.de/playlist.asp
Oleg Chernavin 04/16/2008 09:34 am
I loaded the first URL in the browser and there is the following text only:

titel: COMPLICATED interpret: ROBIN THICKE

The second page doesn't list any plays as well.

Perhaps, these are wrong URLs.

Oleg.
haribo12 04/16/2008 09:42 am
These Links are good....
The frist link - http://www.peppermintfm.de/playlist.php will change its copy after a couple of minutes.
My question is, how to save a text site which does change permanently?
Maybe with different copies, but how?
Oleg Chernavin 04/16/2008 10:30 am
There is File Copies feature in the Project Properties dialog - you can set how many copies to save and how to rename them. This is available in the Pro or Enterprise editions of Offline Explorer.

Oleg.