URL substitution problem

Author Message
Peter Harkness 01/08/2015 05:25 am
I've noticed a problem with some URL substitutions in version 6.9.4156 SR1. Even though I have set the URL substitution rule to "Filenames" OE Pro sends the substitued URL out to the site resulting in a 404 not found.
Oleg Chernavin 01/08/2015 07:07 pm
I need to see the rule - select it, right-click, copy and paste to the forum message. And let me the page address with the URLs that have to be substituted.

Thank you!

Best regards,
Oleg Chernavin
MP Staff
Peter 01/12/2015 02:53 pm
Hi,

Example rule:

URL:
http://updates.emea/nrecord.php?ngroup=*
Replace:
http://updates.emea/nrecord.php?ngroup=*
With:
http://updates.emea/php/*/nrecord.php.htm
Apply to:
Filenames


Example URL - http://updates.emea/nrecord.php?ngroup=4631

The request sent to the server is - http://updates.emea/php/4631/nrecord.php.htm

Oleg Chernavin 01/13/2015 06:16 pm
If I set this URL as a starting one, the rules are not applied to it. Maybe this happens when you update the Project in "Do not download existing files" mode? If so, you have to redownload it completely, because all links are converted in downloaded previously files and only downloading all files again would make correct requests to the server.

Oleg.
Peter 01/14/2015 06:03 am
Oleg, that could be it.

So if a project is first downloaded with URL Substitutes using "Modified and New files" the the substitues will work OK.

If the same project is then downloaded using "Do not download existing files" then the substituted URL's will be used.


Is this correct?
Oleg Chernavin 01/15/2015 02:02 am
It is better to use Download All Files. Because if some file on the disk would appear not changed, it will be not downloaded by Offline Explorer and the program would follow changed links.

Oleg.
Peter 01/16/2015 08:40 am
Oleg, thanks for that. been using OE for years and I'm still finding things out !
Oleg Chernavin 01/16/2015 01:52 pm
You are welcome! New things are being added all the time as well.

Oleg.