Having Trouble Downloading Site

Author Message
Rey 02/01/2012 04:11 pm
Hi,

I am trying to download this site http://documentcentre.eycan.com/ but the text turns to French when clicking on links, and the treeview does not load for the documents.

Can you please help?

Thanks!
Oleg Chernavin 02/02/2012 03:19 pm
I would suggest you to select the Project that partially downloaded the site, click the AutoSave button on the Internal Browser toolbar and then click Browse. Offline Explorer Pro should download missing files.

Regarding the French language - please add the following keyword to the Project Properties dialog - URL Filters - Filename section - Excluded file keywords list:

ddllanguages

It will suppress following the French link. Then you should redownload the project.

Best regards,
Oleg Chernavin
MP Staff
Rey 02/08/2012 04:20 pm
Hi Oleg,

Did you receive my reply?

I am still having issues and wondering if you can help.

Thanks
Rey 02/08/2012 04:21 pm
Thanks Oleg

I am still having issues. It looks like it is not downloading the web control treeview.htc

Here is the source code of the original page. Will OE download this web control?

IMPORT NAMESPACE=TVNS IMPLEMENTATION="/webctrl_client/1_0/treeview.htc"

Have you tried on your end to see if you can download it properly?

I also tried adding the URL Filter to suppress the French link, but now the first page is in French and the rest are in English.

Thanks,
Rey
Oleg Chernavin 02/13/2012 12:06 pm
Rey,

What page has such IMPORT tag? I looked at the http://documentcentre.eycan.com/ but found nothing like this.

Oleg.
Rey 04/17/2012 11:04 am
Hi Oleg,

Sorry, but if you click on any of the links under Engagement, these pages have that webcontrol treeview which does not seem to be picked up the OE.

http://documentcentre.eycan.com/Pages/Main.aspx?SID=65

Please let me know if you get the same issues as I do.

Thanks
Oleg Chernavin 04/17/2012 03:59 pm
OK. I see now. I added support for such tags pf ASP.NET. Here is the updated oe.exe file:

http://www.metaproducts.com/download/betas/OEP3766.zip

Oleg.
Rey 10/17/2012 03:40 pm
Hi Oleg,

I downloaded the latest OE Pro 6.1, but have now lost the treeview within the pages.

Should I still be using the version that you posted above, instead of this latest one?

Thanks!
Oleg Chernavin 10/17/2012 03:53 pm
The latest version is 6.4. Can you describe me more what treeview did you lost? The one with the Projects tab? Or Map? Can you make a screenshot and post a link to it here?

Thank you!

Best regards,
Oleg Chernavin
MP Staff
Rey 10/17/2012 04:07 pm
Sorry, I meant the treeview that is part of pages of a the site that I am downloading:

http://tinypic.com/r/vcxv94/6

The Documents > English... part should be in a treeview, which links to the report (PDF)
Oleg Chernavin 10/17/2012 04:43 pm
I see. Try to Browse With AutoSave button. It is possible that not all script files were downloaded.

If this doesn't help, give me more details about this page - its URL.

Oleg.
Rey 10/17/2012 04:48 pm
Hi Oleg,

I've updated the OE Pro to 6.4, and just tried to Browse with AutoSave but no luck.

The site is the same as posted in this thread:

http://documentcentre.eycan.com/Default.aspx

When clicking any of the links under Engagements, the treeview is lost. Also, the pages are back to French
Rey 10/19/2012 10:39 am
Hi Oleg,

I am still also having issues with English and French pages.

When I click on any link on the first page, the second page will come up in French. I've tried excluding "ddlLanguages" but the issue still exists.

Please advise.

Thanks
Oleg Chernavin 10/21/2012 10:34 am
I excluded:

switchlanguage

in URL Filters - Filename section. Seems that it helped. The tree is visible on the downloaded pages, but it is simple - just 3 items - both in online and offline versions.

Oleg.
Rey 10/22/2012 05:03 pm
Thanks Oleg.

I am getting the treeview but the plus & minus images in the tree are not showing

http://i47.tinypic.com/256ee7p.jpg

It shows that it's trying to download from http://webctrl_client/1_0/treeimages/minus.gif

Can I directly download the images somehow?
Rey 10/22/2012 05:08 pm
Another thing:

My Queue folder is growing very large in size. Is this normal?

Is there somewhere I can manage its content?
Oleg Chernavin 10/23/2012 07:02 am
Queue grows fast because it loads all combinations of the tree view expanded/collapsed nodes. The plus/minus images were correctly loaded with the help of AutoSave. Did you try that?

Oleg.
Oleg Chernavin 10/23/2012 07:05 am
I analysed this more and I have a feeling that the site generates different contents and HTML code in your case.

Can you try to switch the User agent identification to FireFox on the Internet tag of the Ribbon and redownload the site?

Oleg.
Rey 10/24/2012 10:03 am
Did you get my last post?

I switched it Firefox and redownloaded. The plus/minus images are now showing, however when I try to click on them to expand/collapse I get an error:

http://i49.tinypic.com/r2vk82.jpg

Please help.

Thanks!
Rey 10/24/2012 10:07 am
Regarding the Queue,

is it possible to store the Projects, templates and maps directory somewhere else on our network and use a mapped drive? or does it have to be on the same machine as the Download directory?
Rey 10/25/2012 06:39 am
Thanks for your help Oleg.

I switched the User agent to Firefox and redownloaded the site.

I am now seeing the plus/minus icons, however, when I click on to expand/collapse, I receive an error:

[IMG]http://i48.tinypic.com/34e5hxh.jpg[/IMG]

Any ideas?
Oleg Chernavin 10/25/2012 11:42 am
Yes, this folder can be loaded on network drive.

The error appears to be an internal site error - perhaps, it was overloaded by the download.

Oleg.
Rey 10/25/2012 12:39 pm
Thanks Oleg.

What would you suggest I do?

If I were to download from scatch, would that work? Would I still have to set it to download as FireFox just to get the plus/minus images?

Oleg Chernavin 10/26/2012 08:30 am
I was able to fix the issue when downloading under Internet Explorer. Can you please update your oe.exe file:

http://www.metaproducts.com/download/betas/OEP3862.zip

and then redownload the Project in this mode.

Oleg.
Rey 10/31/2012 11:05 am
Hi Oleg,

I've updated the OE.exe with the file that you provided. I've started downloading, but noticed that pages are only downloading in French.

I've excluded ddlLanguages and switchlanguage, re-downloaded, but still only French pages.

Please advise on what to exclude.

Thanks
Oleg Chernavin 10/31/2012 03:18 pm
Try to open the site online in the internal browser before downloading and switch to English.

Oleg.
Rey 11/05/2012 02:51 pm
OK - I've opened the site in the browser and switched to English.

Re-downloaded the site, and the first page downloaded in English - which is good

But now when I click on links on the first page, the next page shows up in French again!?

Please advise...
Oleg Chernavin 11/06/2012 04:26 am
Rey,

I don't know what to say. I don't have any French page when I download the site with the suggested settings. I am sorry, I really out of ideas on what to do.

Can you try to make this download on some other computer? Would this make a difference?

Oleg.