Access Violation when entering Queue tab

Author Message
Terry 01/07/2012 11:29 am
Offline Explorer Pro 6.1.3698 Release.

It comes and goes, but when entering the Queue tab (almost always from the Projects tab via Ctrl-Shift-Tab) I receive an Access violation at address 00685030 in module 'OE.exe'. Read of address 00000004.

This usually comes up with the Queue tab blank, with a single row with a blue highlight but no data in it. I hit OK enough times and it goes away and the Queue tab fills with proper information. Occasionally I only need to hit OK once, sometimes around 25 times. Program does continue to function after hitting OK enough times for the modal dialog to go away.

Terry
Oleg Chernavin 01/08/2012 05:35 am
Can you please try this version:

http://www.metaproducts.com/download/betas/opsetup.exe

Would it work correctly with the Queue tab?

Best regards,
Oleg Chernavin
MP Staff
Terry 01/08/2012 06:37 am
No such luck. Just received the same error. Now it is address 006851D4, but still reading 00000004. Started a project downloading, Ctrl-Shift-Tab to Queue, and received the error.

As an FYI, Windows 7, x64, SP 1.

Terry
Oleg Chernavin 01/08/2012 07:11 am
Please replace oe.exe file with the following update:

http://www.metaproducts.com/download/betas/OEP3712.zip

Would it fix the error?

Oleg.
Terry 01/09/2012 05:56 am
It's hard to confirm the error is gone, but it happened about 50% of the time. I've now tried swapping about 6 times (with new project downloads which seem to cause it more often) and it hasn't happened, so I'd say that EXE probably takes care of it, but only more trial will show if it is still happening.

Terry
Oleg Chernavin 01/09/2012 01:36 pm
It never happened to me. But I examined the code and there was some situation possible to cause it. However I can't understand how it may occur. Anyway, another precaution and a check is not bad to have.

Please let me know if it occurs again. But I hope, it is finally fixed.

Oleg.