Offline Explorer won't install

Author Message
newbie 12/02/2011 07:10 am
Hello,

I wanted to give Offline Explorer Pro a try, but it fails to install in Windows 7 SP1 x86. Windows 7 says:



Offline Explorer executable stopped responding

A problem stopped the correct operation of the program. Close the program.



I'm using a standard user account. I ran the installer with administrator privileges. I'm also running Microsoft EMET.

Could you provide assistance?


Thank you


Oleg Chernavin 12/02/2011 07:11 am
Can you please try the updated version:

http://www.metaproducts.com/download/betas/opsetup.exe

Please let me know how it works. Thank you!

Best regards,
Oleg Chernavin
MP Staff
newbie 12/05/2011 06:35 am
Hello,

Thank you for the quick reply.

I downloaded the installer from the link you provided me with, but it still fails to install. I'm wondering if it can have anything to do with Microsoft EMET (Enhanced Mitigation Experience Toolkit)?

Link for Microsoft EMET: http://www.microsoft.com/download/en/details.aspx?id=1677

In EMET user interface I got the following settings:

DEP - Always On
SEHOP - Application Opt Out
ASLR - Application Opt in

I algo got explorer.exe in the Configure Apps options, so that EMET protects it against exploits.

I'm going to see if I can find anything that could point to a solution, but if you could also do some investigation on your side, it would be great. EMET could be conflicting with Offline Explorer, and it would be great if you could see if you could make Offline Explorer compatible.


Thank you
Oleg Chernavin 12/05/2011 06:38 am
Thank you for the details! Yes, after installing EMET I found that DEP - Always On stops the installer from being started.

I added code to see what point is responsible for that. But the error happens before any code that I wrote. I will try to further investigate the issue. I also started installed Offline Explorer and it worked correctly with enabled DEP.

You may try to disable DEP just to install Offline Explorer Pro. Or I can make an archive with installed program. You will have to unpack it to some folder on your system and start.

Oleg.
newbie 12/07/2011 10:57 am
If you could provide the archive, it would be great then. Hopefully, you'll come with a fix for the issue.

Thank you for the great support!!
Oleg Chernavin 12/07/2011 10:57 am
Yes, here is the link:

http://www.metaproducts.com/download/betas/OEP6.zip

Oleg.