Java Script Runtime Error in the Internal Browser of Offline Explorer Pro

Author Message
Earl 06/07/2011 05:50 pm
In Offline Explorer Pro I encountered a chronic problem. When trying to use the internal browser on some sites the following error would have to be cleared off the screen over a dozen times.

Here is the text of the error:

A Runtime Error has occured. Do you wish to Debug?
Line 1
Error: Syntax Error
[Yes] [No]

The Line number would vary.

This occured both in Offline Explorer Pro v3. And in Offline Explorer Pro v5.

Here is my solution:
1. Close Offline Explorer Pro
2. Open MS Internet Explorer
3. Go to the Menu:
Tools|Internet Options|Advanced (tab)|Browsing (section)
and make sure check box "Disable script debugging [Other]" is checked.
In my case it was unchecked.
4. Click the "Apply" button in the lower right corner.
5. Open Offline Explorer Pro. The error statements should should not longer appear.

As a test, while Offline Explorer was open to one of the offending web pages, I toggled the "Disable script debugging [Other]" checkbox back off again, then hit the "Apply" button. Instantly the error box appeared in the Offline Explorer Pro window.

The "Disable script debugging [Internet Explorer]" checkbox however did not appear to make any difference either way.
Oleg Chernavin 06/08/2011 09:22 am
Can you please let me know MS Internet Explorer version on your computer? I will try to improve the code to suppress such errors.

Thank you!

Best regards,
Oleg Chernavin
MP Staff
Steve G 06/09/2011 02:07 pm
Oleg,

"About Internet Explorer" window lists this information:

Windows Internet Explorer 7
version 7.0.5730.11
Cipher Strength: 128 bit
Update Versions: 0

Thanks for your professional commitment to improving your products.
SG
Steve G 06/09/2011 02:24 pm
I was inconsistent on my posting names:
"Earl" and "Steve G" are both me.
Oleg Chernavin 06/10/2011 08:08 am
Can you also tell me the links where it happens? What URL/page should be downloaded to reproduce this script error?

Oleg.
Steve G 06/11/2011 01:11 pm
Oleg,

I just tried these two sites and got the error statements:
http://abcnews.go.com/
http://www.coasttocoastam.com/

I am running Offline Explorer Pro 3.8 on Windows XP.

The process:
1. I deselected the "Disable script debugging (other)" checkbox in MS Explorer.
2. Then downloaded just the opening page, on the two sites mentioned above.
3. Then when I click on the projects list in OE to open the page in the internal browser the errors appear.

Again, when I reselect the box, the errors disappear.

SG
Oleg Chernavin 06/14/2011 09:37 am
Can you try this version:

http://www.metaproducts.com/download/betas/OEP3376.ZIP

Does it suppress this error window?

Oleg.
Steve G 06/15/2011 05:48 am
Oleg,
I conducted four experiments with the OE Pro 5.9 you supplied.
My summary would be:
1. The error windows are gone. But the error audio has remained.
[though in one case with the "ABC News" page test, one script-error window did show up behind all the forward windows. But only once and never again.]
2. A new problem shows up with the "ABC News" page but not with the Coast to Coast page. The problem is: When the ABC project line on the left is double-clicked, the page displays for a few seconds and then is replaced by an error page (described below).

Below are the details of my four trials.

Setup 1 (using ABC News Webpage):
-------
1. The "ABC" page is downloaded into the OE 5.9 program (supplied by Oleg).
2. The check/uncheck state of MS Internet Explorer boxes are:
Disable script Debugging (Internet Explorer) CHECKED
Disable script Debugging (other) CHECKED
"Apply" button clicked

Result 1 (using ABC News Webpage):
-------
1. In OE 5.9, I double click the downloaded "ABC" project line now listed on the left.
2. The ABC page displays for a few seconds and then is replaced by an error page, in the OE browser, which states:
<<This program cannot display the webpage
Most likely causes:
You are not connected to the Internet.
The website is encountering problems.
There might be a typing error in the address.
...>>

Setup 2 (using ABC News Webpage):
---------
Disable script debugging (Internet Explorer) CHECKED
Disable script debugging (other) UNCHECKED
"Apply" button clicked

Result 2 (using ABC News Webpage):
---------
1. Same as "Result 1:" except the script error-window audio sounds 6 to 12 times. The small script-error window does not show however.
2. As in "Result 1" above, the ABC page does display for a few seconds and then is replace by the error page noted above.

Setup 3 (using Coast to Coast Webpage):
---------------------------------------------
Check boxes are same as Setup 1 (ABC) above
Disable script Debugging (Internet Explorer) CHECKED
Disable script Debugging (other) CHECKED
"Apply" button clicked

Result 3 (using Coast to Coast Webpage):
---------------------------------------------
The page loads fine. I can even click on a hot link and load a page from the next level down. No problem.

Setup 4 (using Coast to Coast Webpage):
---------------------------------------------
Check boxes are same as Setup 2 (ABC) above
Disable script debugging (Internet Explorer) CHECKED
Disable script debugging (other) UNCHECKED
"Apply" button clicked

Result 4 (using Coast to Coast Webpage):
---------------------------------------------
The script error-window audio sounds 6 to 12 times. But the small script error window itself does not show.
But other than the sounds, the page seems fine and stays open fine without being replaced by the error page as above with the ABC News page.

Regards,
Steve G.
Oleg Chernavin 06/15/2011 05:52 am
Steve,

It is the advertisement module that causes the problem. Just remove it from the Map:

adsyndication.msn.com/delivery/getads.js

Regarding audio - yes, it is correct. Because the error windows actually appear and they produce the sound. However Offline Explorer closes them immediately. To avoid such error windows you need to adjust IE settings.

Oleg.
Steve G. 06/16/2011 02:10 am
Oleg,

Got it.

I use Offline Explorer a bunch. Great program.

Thanks for your assistance.

Steve G.
Oleg Chernavin 06/16/2011 06:46 am
You are welcome!

Oleg.