After downloading about 20-30 pages, it loses internet connection

Author Message
Lah 07/02/2010 12:17 am
Yeah, so I've tried downloading every different trial you have and they all react the same on my system, and I have no idea why.

Every time I run it, it successfully downloads 20-30 pages, then it tries to connect to the same website and cannot. Then when I try to use the browser to connect to the internet (the one build into OE) it also does not connect, although sometimes it connects for a few seconds afterwards but dies after that.

I have tried:

1) Reducing the speed
2) Reducing the number of connections
3) Different websites
4) Doing it with my firewall on and off
5) Uninstalling and re-installing
6) Turning off the built in server
7) Various other tweaks.

Additionally, and obviously, I am able to browse outside of OE throughout the process.

Any idea why this is happening?
Oleg Chernavin 07/02/2010 05:00 am
Please try to change the "Use alternative connection method" box state on the Internet tab of the Ribbon. Would it help?

Best regards,
Oleg Chernavin
MP Staff
Lah 07/03/2010 01:24 pm
Hi Oleg,

That seemed to fix it!

Thanks!
Oleg Chernavin 07/03/2010 02:26 pm
Great! Is it unchecked now?

Oleg.
Lah 07/03/2010 09:03 pm
Hi Oleg,

No, after checking it it started working.

I have another question - is there something I am missing regarding the filename filters?

As in, if there is such a URL:

http://www.domain.com/forum/newmember.php?p=1244&postcount=2&phpMyAdmin=e813aee4b25cea30bd3b1a0804d574c2

How do I prevent the software from downloading these pages?

I have tried adding:

^newmember.php*
*newmember.php*
*newmember*

to the filename exclude list, but it still downloads it.

Do i have to stop and start for it to be activated even though I click apply? I've tried pausing and restarting but it still doesn't exclude these.

Thanks.
Oleg Chernavin 07/04/2010 07:07 am
Actually, it is enough to add

newmember.php

to the URL Filters - Filename - Excluded list.

Please also check the File Filters - Text - its Location field should be "Load using URL Filters settings".

Oleg.
Lah 07/04/2010 10:06 am
Hi Oleg,

if it is already in the queue does the filter not apply?

Because I've done what you said but it still loads.
Oleg Chernavin 07/04/2010 10:17 am
Yes, it doesn't affect the files in the Queue. It will not allow to add such links to Queue anymore.

If you want to get rid from these URLs in the Queue, press F9 to pause, go to Queue tab, right-click and choose Select By Mask. Then abort the selected files.

Oleg.
Lah 07/04/2010 10:26 am
What I don't understand is this -

Say I want to just download images from a site.

Under "file filters" if I unclick everything except the images tab, it spiders the whole site and only downloads images.

If I click the text one and enable use url filter settings it will download the actual HTML pages too. If I unclick the document extension list in the file filter - text tab, it doesn't even spider those pages for links to find images.

So how do I use URL filters to prevent the program from spidering certain pages, yet still spider the rest of the pages for images, and not download any HTML documents?
Oleg Chernavin 07/04/2010 10:44 am
You should have File Filters - Text - check all extensions there and select "Load using URL Filters" in the Location field. Then uncheck the Text category in the left tree.

It should work.

Oleg.