Exported .EXE doesn't work - can't find default.htm

Author Message
Prizm 01/11/2010 07:20 am
I have downloaded an online forum, and it works fine within Offline Explorer. I tried to use the export to EXE option, and it compiles it fine. But when I run the EXE I get this:

---
(URL) http://127.0.0.1:5000/www.downloadedforum.com/default.htm

Document not found
This page is not accessible offline. Possible reasons: either it was an invalid link on the server or Project settings do not allow the page to be downloaded.
---

It's trying to load default.htm. In the original downloaded files, the default.htm file is there so I don't know why it's having a problem when compiling to EXE?

Oleg Chernavin 01/11/2010 10:09 am
I tested this with Offline Explorer Pro 5.7 Service Release 2 and it works correctly. Do you have the latest version?

Best regards,
Oleg Chernavin
MP Staff
Prizm 01/12/2010 06:31 am
I originally tried with Enterprise (latest version downloaded from the website). I've now tried it with Pro, and now it won't even make a proper .EXE. The EXE created with Pro only ends up being about 256kb. I click Export and nothing happens. No progress meter or anything. The EXE created with Enterprise was 26MB.

I don't know how else to make this work. I'm using Windows 7 64-bit. I've tried running the program as Administrator and that doesn't make a difference.

Is there something I can change with the source files? (I assume it uses the files that are located in C:\Download).

thanks
Prizm 01/12/2010 08:20 am

ok, after a lot of hassle, I think I might know what the problem is. Since I'm downloading a forum, I put in a username and password in the settings. I then found it was creating a ton of SID= files. At one point it was downloading some 13,000 files when there should only be under 3,000.
I then took the username and password out and told the program to ignore username/password for the website. This time it downloads about 2,200 files. Now everything seems fine in the internal browser.
I then export to EXE, and again everything seems fine. I can browse through the exported EXE, however certain pages will not show up. However, if I test them in Offline Explorer's internal browser, the pages work fine.

I then found that the missing pages are located in one of the %&Ovr0 folders. It seems every missing page is in one of these overload folders! For some reason, the exported EXE won't read files in the overload folders? Maybe that's where it put default.htm the last time I tried to export to EXE.

I moved all the overload files to the main folder and deleted the %&Ovr0 folders. Then I tried exporting to EXE again. Nope, the progress meter stops halfway, and I have a half-completed website in EXE format.

Oleg Chernavin 01/12/2010 09:21 am
I made an improvement. Please download the file:

http://www.metaproducts.com/download/betas/OEBrowse.exe

Replace the previous oebrowse.exe file in the Offline Explorer Pro installation directory with the new version. Make the export with OVR folders to EXE file again.

If this will also fail, please send me several examples of the URLs that fail. I will download them and try to reproduce the faulty export.

Oleg.
Prizm 01/12/2010 05:22 pm
Hi Oleg,

I got it working by turning off the overload directory option and downloaded the website again. Now it works fine and converts to EXE fine (in Enterprise). So as long as I turn off overload folders, it works perfect.

I just tested again with overload directories turned on and using the new OEBROWSE.EXE, but that makes it worse. Now it only goes about one level down (I can see a list of topics on the forum). If I click any topics to view the posts, now it says it can't find the page. If I browse the offline forum in OE, it works fine.
Oleg Chernavin 01/13/2010 06:36 am
Can you tell me what forum you are downloading and whether I need to logon it before the download? And few examples of links that do not browse correctly in EXE file.

Oleg.