URL Substitute

Author Message
Steven 08/29/2009 11:46 pm
I was trying to download the page: http://www.businessweek.com/magazine/news/articles/business_news.htm

and was trying to download print version of the articles on this page.
Steven 08/29/2009 11:47 pm
So I wrote URL Substitutes as

In URL

www.businessweek.com/magazine/content/*_*/*.htm?chan=*

Replace htm?chan=*

With htm

In URL

www.businessweek.com/magazine/content/*_*/*.htm

Replace magazine

With print/magazine

And it tested well. When I entered

http://www.businessweek.com/magazine/content/09_36/b4145035674883.htm?chan=magazine+channel_top+stories

it pops up as

http://www.businessweek.com/print/magazine/content/09_36/b4145035674883.htm
Steven 08/29/2009 11:48 pm
And I began downloading. But here a problem poped out. It works well with URLs such as

http://www.businessweek.com/magazine/content/09_36/b4145040683083.htm

and those links were successfully directed to the print version.

However, links such as

http://www.businessweek.com/magazine/content/09_36/b4145035674883.htm?chan=magazine+channel_top+stories

were not directed to the print version and were downloaded as they are.

But according to the two URL Substitute rules that I wrote. The first rule will delete "?chan=*" and the
second rule will add "print/" before "magazine". And when I tested the URLs it all turned out well. Why
weren''t links such as

http://www.businessweek.com/magazine/content/09_36/b4145035674883.htm?chan=magazine+channel_top+stories

directed to the print version?

I set the level to 1 and no other filters were added.

It may be a bug with the current version (I am using the latest version).

I''m looking forward to your reply. Thank you very much.
Steven 08/29/2009 11:51 pm
I have alread checked the box "Apply all matching rules"in the URL Substitutes dialog.
Steven 08/29/2009 11:52 pm
Here are my settings of the Project:

[Object]
OEVersion= 5.6.0.3094
Type=0
IID=7017
Caption=Businessweek
URL=http://www.businessweek.com/magazine/news/articles/business_news.htm
Lev=1
Weekday=257
LimTSize=10000
LimNumber=5000
LimTime=100
FTText.Exts=htmlhtmaspaspxjspstmstmlidcshtmlhtxtxttextxspxmlrxmlcfmwmlphpphp3
FTImages.Exts=gifjpgjpegtiftiffxbmfifbmppngipxjp2j2cj2kwbmplwf
FTVideo.Exts=mpgavianimpegmovflvfliflcvivrmramrvasfasxwmvm1vm2vvobsmilmp4
FTAudio.Exts=wavriffmp3midmp2m3uravocwmaape
FTArchive.Exts=ziparcgzzarjlhalayleirarcabtarpakacejarpdftgzexe
FTUDef.Exts=jscssssivbsdtdxslswfclassent
FTText.B=ooxooo
FTImages.B=ooxooo
FTVideo.B=xoxooo
FTAudio.B=xoxooo
FTArchive.B=xoxooo
FTUDef.B=ooxooo
FTOther.B=ooxooo
FTSizes=0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,3,3,3,0,3,0
NotIgnoreLogout=False
RSrvsBx=1
RProt=255
LastStart=86:254:123:203:205:142:227:64:
LastEnd=231:156:178:205:205:142:227:64:
LastStarted=2009-8-29 10:20:46
LastEnded=2009-8-29 10:21:09
S200=19
S304=128
SPar=42
SSav=19
SLast=304
SSiz=421567
SMdf=2
LFiles=147
LSize=128116
SubstsB=d3d3LmJ1c2luZXNzd2Vlay5jb20vbWFnYXppbmUvY29udGVudC8qXyovKi5odG0/Y2hhbj0qCWh0bT9jaGFuPSoJaHRtDQp3d3cuYnVzaW5lc3N3ZWVrLmNvbS9tYWdhemluZS9jb250ZW50LypfKi8qLmh0bQltYWdhemluZQlwcmludC9tYWdhemluZQ0K
ApplyAllSubsts=True
ImgDim=0,0,0,0
PrevURL=http://www.businessweek.com/magazine/news/articles/business_news.htm
ConvertRSS=True
LIndexed=False
IndexFiles=False
Oleg Chernavin 08/30/2009 09:10 am
OK. I fixed this issue. Here is the updated oe.exe version:

http://www.metaproducts.com/download/betas/OEP3101.ZIP

Best regards,
Oleg Chernavin
MP Staff
Steven 08/30/2009 09:27 am
> OK. I fixed this issue. Here is the updated oe.exe version:
>
> http://www.metaproducts.com/download/betas/OEP3101.ZIP
>
> Best regards,
> Oleg Chernavin
> MP Staff

Thank you so much! By the way, do I need to replace the exe even when I''m using Portable Offline Browser?
Oleg Chernavin 08/30/2009 09:37 am
No, this file will work for Offline Explorer Pro version only - this topic is devoted to this edition.

Oleg.
Steven 08/30/2009 09:57 pm
This time another problem popped up. It seems to have downloaded all the print versions that I required. But when I choose to browse the project in the built-in explorer, all the links were not replaced. (That is to say, although it has downloaded all the files, but the starting page,which is

http://127.0.0.1:800/Default/www.businessweek.com/magazine/news/articles/business_news.htm

does not lead to any of the pages downloaded).
Oleg Chernavin 08/31/2009 06:18 am
I think, I fixed that. Please try this version:

http://www.metaproducts.com/download/betas/OEP3101.ZIP

Oleg.

Steven 08/31/2009 06:35 am
I''m afraid that it seems that the same problem still exists, would you please take a look at it again?
Oleg Chernavin 08/31/2009 06:44 am
Yes, I need the Project settings from you again to reproduce.

Oleg.
Steven 08/31/2009 06:58 am
Have attached it in the email. Thanks!
Oleg Chernavin 08/31/2009 08:42 am
Please try this:

http://www.metaproducts.com/download/betas/OEP3101.ZIP

Oleg.