OE 5.5 and IE8

Author Message
Nick 05/23/2009 12:48 am
Hi
After installing IE8 on my machine, something weird is happening. http://127.0.0.1:800/ gives me an error "The website cannot display the page", and none of my offline sites work. If I go http://localhost:800/ instead, it DOES work. It appears to be something with IE. Firefox can display both ok. Any ideas how to fix this?
Oleg Chernavin 05/23/2009 09:26 am
I searched or possible problems with IE 8 and 127.0.0.1 and found nothing. I have no good idea on that right now. Try to change the port from 800 to some other number in the Options dialog - Connections section. Would this make a change?

Best regards,
Oleg Chernavin
MP Staff
Nick 05/23/2009 02:05 pm
> I searched or possible problems with IE 8 and 127.0.0.1 and found nothing. I have no good idea on that right now. Try to change the port from 800 to some other number in the Options dialog - Connections section. Would this make a change?
>
> Best regards,
> Oleg Chernavin
> MP Staff
I tried changing the port and it doesnt make a difference. Any way not to use the IE engine for OE? I''ve added 127.0.0.1 to its trusted sites and it''s still not going through...
Oleg Chernavin 05/25/2009 04:46 am
Other browsers do not allow to embed them in applications. Only MS IE is really developers-friendly. One way is to uncheck the Internal browser in the View tab of the Ribbon. This way, browsing projects will use your default browser.

I can also add a setting to use "localhost" instead of 127.0.0.1, if you want.

Oleg.

Nick 05/26/2009 11:12 pm
>
> I can also add a setting to use "localhost" instead of 127.0.0.1, if you want.
>
> Oleg.
>
>
That would be great!
I''m sure others will run into this problem as well as IE changes. Unchecking the Internal browser option opens the pages in Firefox ok. Thanks for the tip.
Oleg Chernavin 05/27/2009 09:55 am
OK. I will think on where to add this setting.

Oleg.
Oleg Chernavin 05/27/2009 10:08 am
By the way, this issue could be related with your firewall settings. Can you please see if Windows Firewall or other firewall allow Offline Explorer''s server on 800 port?

In this case localhost may refer not to 127.0.0.1 address, but your real address on the computer.

Oleg.
Nick 05/28/2009 10:45 pm
> By the way, this issue could be related with your firewall settings. Can you please see if Windows Firewall or other firewall allow Offline Explorer''''s server on 800 port?
>
> In this case localhost may refer not to 127.0.0.1 address, but your real address on the computer.
>
> Oleg.
While troubleshooting I disabled my firewall, and the same problem remained. I also tried changing the ports, such as 799, 701, 650, etc...no luck.
Oleg Chernavin 05/29/2009 07:10 am
Can you plesae try to download the following file:

http://www.metaproducts.com/files/Localzone.zip

Unzip it and run localzone.reg file. It should add a setting of Your Computer zone to MS IE 8.0 Internet Settings - Security dialog. It was suggested by Microsoft developers.

Please let me know if this solves the issue. Thank you!

Oleg.
Nick 05/30/2009 02:03 am
> Can you plesae try to download the following file:
>
> http://www.metaproducts.com/files/Localzone.zip
>
> Unzip it and run localzone.reg file. It should add a setting of Your Computer zone to MS IE 8.0 Internet Settings - Security dialog. It was suggested by Microsoft developers.
>
> Please let me know if this solves the issue. Thank you!
>
> Oleg.
Nope...didn''t work. I already had that setting in my registry but i ran the .reg file anyways. Before this I added localhost and 127.0.0.1 to Trusted Zones. No difference...

Thanks for following up though.
Oleg Chernavin 06/02/2009 06:52 am
I am making a workaround now. Can you tell me what error do you see in the Internal browser when navigating to 127.0.0.1 ?

I get a page like res://ieframe.dll/navcancl.htm#http://127.0.0.1:800/ when I navigate to a non-existing address.

Do you have the same? Thank you!

Oleg.
Nick 06/03/2009 02:46 am
> I am making a workaround now. Can you tell me what error do you see in the Internal browser when navigating to 127.0.0.1 ?
>
> I get a page like res://ieframe.dll/navcancl.htm#http://127.0.0.1:800/ when I navigate to a non-existing address.
>
> Do you have the same? Thank you!
>
> Oleg.

The website cannot display the page
HTTP 500
Most likely causes:
The website is under maintenance.
The website has a programming error.

What you can try:
Refresh the page.

Go back to the previous page.

More information

This error (HTTP 500 Internal Server Error) means that the website you are visiting had a server problem which prevented the webpage from displaying.

Oleg Chernavin 06/03/2009 05:39 am
Oh, this is interesting. Maybe it is some internal OE''s Web server issue. I haven''t seen this yet, but can you make a test?

Press Ctrl+Q in Offline Explorer. This opens Log window. Click on the first button on the Log toolbar to enable log. Then check all items in the Filter button. Browse some Project in the Internal browser offline. Would the log show any line from Internal Server?

Oleg.
Oleg Chernavin 06/03/2009 05:41 am
Also, please open MS IE - Internet Settings dialog - Advanced tab and uncheck the "Friendly HTTP error messages" box. Click OK and try to browse again - what text will be there?

Oleg.
Nick 06/04/2009 01:54 am
> Oh, this is interesting. Maybe it is some internal OE''''s Web server issue. I haven''''t seen this yet, but can you make a test?
>
> Press Ctrl+Q in Offline Explorer. This opens Log window. Click on the first button on the Log toolbar to enable log. Then check all items in the Filter button. Browse some Project in the Internal browser offline. Would the log show any line from Internal Server?
>
> Oleg.
No log shows up using the above.
Nick 06/04/2009 01:56 am
> Also, please open MS IE - Internet Settings dialog - Advanced tab and uncheck the "Friendly HTTP error messages" box. Click OK and try to browse again - what text will be there?
>
> Oleg.
I get this:

Server Error
The following error occurred:
[code=CANT_CONNECT_LOOPBACK] Cannot connect due to potential loopback problems


--------------------------------------------------------------------------------
Please contact the administrator.

Could it have to do with the lmhost file? I tried tweaking it around a bit before with no success.
Oleg Chernavin 06/04/2009 06:18 am
I think, it is related with proxy server. Please try this hint:

http://www.tech-archive.net/Archive/Internet-Server/microsoft.public.inetserver.iis/2004-03/0815.html

Oleg.