OE stops after a certain number of files

Author Message
Tyler 03/21/2009 09:12 pm
I seem to have a strange problem with OE Pro, version 5.4.2972 Service Release 1. I start a project, and sometimes it will only
download around 44 files before the download just stops. I can''t get it to do this consistently, but it seems to be happening quite a bit. If I restart OE, the problem goes away until I download another project or two, then it starts right back up again. For example, the status bar says:
Ready Download stopped - 44 file(s) - Last download from 3/21/2009 6:09:37 PM to 6:09:37 PM Speed: 90,425 bytes/s
What could be going on here?
Tyler 03/21/2009 09:44 pm
Maybe this will help. This happened when I pressed F5 to start something:
---------------------------
MetaProducts Offline Explorer Pro
---------------------------
Access violation at address 0072D472 in module ''OE.exe''. Read of address 0000002E.
---------------------------
OK
---------------------------
Oleg Chernavin 03/22/2009 06:49 am
I am sorry for this problem. It looks familiar to me. I fixed a problem recently and updated the setup file on our server. Can you please try to download and install it?

http://www.metaproducts.com/download/opsetup.exe

The version number is exactly the same, but it should be an improved version.

Best regards,
Oleg Chernavin
MP Staff
Tyler 03/22/2009 02:55 pm
That version still gives me the error. I can''t get it to happen on a local test, but I can after downloading a few remote projects.
Oleg Chernavin 03/23/2009 08:06 am
OK. I made some other changes. Can you please download the updated version here:

http://www.metaproducts.com/download/betas/oep2978.zip

Unzip the file and replace the old oe.exe file with the new one. Please let
me know how it works.

If any error happens, please let me know the details again. Thank you!

Oleg.
Tyler 03/24/2009 05:09 am
I tried this version, and the crash seems to be gone. Downloads still stop after a certain number of files sometimes until
I restart the program. I''m sure this can be fixed if we can figure out what''s going on. For example, on this machine,
if I start my project from the beginning with alt-f5, let it download,
then press control f5 once (or sometimes twice if that one completes), the status line says "download stopped" and I can''t download any more projects until I restart the program. If I press alt f5 to start over, one of two things happens -
The status line says ready, downloaded 44 files, or if I hit it again it says download stopped, 43 files.
Is there anything I can do that will help find a fix for this problem?
Oleg Chernavin 03/24/2009 07:57 am
Maybe it just depends on the Project''s File Modification Check settings? If you press Ctrl+F5 it works as if you have "Do not load existing files". For example, if you downloaded a Project completely - all files that correspond project settings (Level, URL Filters, etc.) were downloaded. Then Ctrl+F5 will get no files - because all files are already there.

Ctrl+F5 will be useful either if you stopped first project download and you want to continue. Or you changed Project settings after a complete download (e.g. increased Level setting) and want to get additional files.

Oleg.
Tyler 03/24/2009 08:27 am
that doesn''t seem to be the issue. I can get this to happen even after I delete and recreate the project. It''s happened a few times, and restarting OE seems to make it work again until I download another project. If I delete the project and create it again, then press F5, it should download all of the files, not just 44 and stop.
Oleg Chernavin 03/24/2009 09:03 am
I tried and cannot reproduce this. I selected a Project, pressed Alt+F5, waited until download completes (it was a small one - about 50 files). Then used Ctrl+F5 - it loaded no files this time, which is normal because all files are already on the disk.

Then I used Ctrl+F5 again - to make sure.

Then selected another Project and pressed F5 - it started loading normally.

Can you press Ctrl+Q to see if there are errors in the Log?

Oleg.