Not following Flash link correctly

Author Message
cpedrick 07/15/2008 01:28 pm
I am getting a "Host content not found." message when OEPro V4 tries to follow a link from within a Flash object.
I have tried adding the page to the URLs in the project properties, but OEPro still can''t seem to follow the link to the proper page in the site offline.
I believe this may be because the link does not include the full domain name - it is a relative link beginning at the root directory. (For example: the link reads /content/building/start.asp rather than http://www.mydomain.com/content/building/start.asp.)
OEPro follows such relative links correctly in the .asp pages in the site. Won''t it follow them when they are in a Flash object?
This is a major issue for creating an offline copy of this site. I need these links to work. We can''t use the fully qualified links because we work in different development environments and it would require too much maintenance when moving Flash objects between environments.
Thanks for any assistance you can provide,
Carolyn
Oleg Chernavin 07/15/2008 01:30 pm
I would suggest you to select the Project that partially downloaded the site, click the AutoSave button on the Internal Browser toolbar and then click Browse. Offline Explorer Pro should download missing files.

Best regards,
Oleg Chernavin
MP Staff
cpedrick 07/15/2008 01:39 pm
> I would suggest you to select the Project that partially downloaded the site, click the AutoSave button on the Internal Browser toolbar and then click Browse. Offline Explorer Pro should download missing files.
>
> Best regards,
> Oleg Chernavin
> MP Staff

I have tried that several times. Clicking the link in the Flash object continues to give me "host not found". (likely because OEPro is looking for HTTP:// and the path with no domain name...)

The file is downloaded because identical links to that file within .asp pages in the site do work. The only links that don''t work are those within the Flash object.

Any further thoughts?

Thanks!
Carolyn
Oleg Chernavin 07/15/2008 01:45 pm
You can give me the link to this page with Flash and tell what exact links fail. I will see if I can do something or not.

Oleg.
Oleg Chernavin 07/15/2008 02:20 pm
Could you please make a simple Project that downloads only this page with Flash object and these links? Then download it and make a backup copy of it. Then send it to support@metaproducts.com. I will see what exactly goes wrong there and try to fix it.

Oleg.
cpedrick 07/15/2008 02:36 pm
This is a propriatary site currently in development. I will need your assurance that all pages will remain completely confidential, be viewed only by you, and that the source file will be deleted as soon as you are finished troubleshooting.

Also, how do I restrict the project to only take the problem page and one page lower? I limited levels to 1, but it is pulling other pages on the same level too.

thanks for your help.

Carolyn
Oleg Chernavin 07/15/2008 02:44 pm
I just got your E-mail from our support and answered it.

> Also, how do I restrict the project to only take the problem page and one page lower? I limited levels to 1, but it is pulling other pages on the same level too.

Yes, Level=1 should solve this. Sometimes extra pages may be downloaded because of scripts where it is hard to tell exactly if level limit should be obeyed or not. But I will need more details to tell exactly.

Oleg.