Issues with downloading DPReview Forum

Author Message
Virginian 09/16/2007 09:08 am
I have ussue downloading DPReview Nikon Forum:

http://forums.dpreview.com/forums/forum.asp?forum=1034.

The start page is OK, but when I click any thread, for example:

http://forums.dpreview.com/forums/readflat.asp?forum=1034&thread=24831472

Offline Explorer URL string looks like:
http://127.0.0.1:800/Default/forums.dpreview.com/default.htm/forums/read.asp?forum=null&message=24831472

As you can see, URL string doesn't have proper forum number parameter, just "null" instead of "1034".

Thanks in advance,

Virginian



Oleg Chernavin 09/16/2007 11:08 am
I tried to load from that URL, but the page contains no links to the messages. What can be wrong? Should I logon the site?

Best regards,
Oleg Chernavin
MP Staff
Virginian 09/16/2007 10:29 pm
Oleg,

Thank you for a prompt reply.

Login is not required unless you want to post a message.

Goto the DPReview main page:

http://dpreview.com

On the left sidebar position mouse over "Discussion Forums", on the extended submenu select "Nikon D80/D70/D50/D40 Forum" or any other forum. After that select any thread with the "Autosave" option On. You will see something like

"http://127.0.0.1:800/Default/forums.dpreview.com/default.htm/forums/read.asp?forum=null&message=24798546" in the address box.

Vlad





> I tried to load from that URL, but the page contains no links to the messages. What can be wrong? Should I logon the site?
>
> Best regards,
> Oleg Chernavin
> MP Staff
Oleg Chernavin 09/17/2007 04:08 pm
Yes, autosave will fail here, because of the @ symbol in the Address bar when browsing offline. But if you would manually change it to ?, this will work well.

Oleg.
Virginian 09/17/2007 11:50 pm
> Yes, autosave will fail here, because of the @ symbol in the Address bar when browsing offline. But if you would manually change it to ?, this will work well.
>
> Oleg.

Oleg,

It would be counterproductive replacing @ for every page. I don't fully understand the logic behind @ and ? swap, but offline browsing works fine on the Privet forum with links like

http://127.0.0.1:800/Default/forum.privet.com/viewtopic.php@t=39511&sid=eaccf3f20f0f500787915ef8725e295a.

Autosave is the only option when I download forums like Privet, Videomax etc. because it makes possible to download only interesting threads. Setting level limit more the 0 makes number of downloaded files skyrocketing. Just look at the typical forum page, for example,

http://forum.privet.com/viewforum.php?f=4

and you will see the problem. You can use filtering, but it doesn't help much. I still nee some solution for Dpreview and I think this is not the only forum affected.


Thanks in advance,

Vlad
Oleg Chernavin 09/18/2007 08:20 am
Sorry, I don't have any better solution right now. This forum uses scripts in included .js files, which complicates things.

Oleg.