WML Wap Site

Author Message
Kekmaklu 08/07/2007 04:22 am
Dear all,

How to download this wap site http://chat.2wap.org ? anybody can help to guide using offline explorer. how do i enable WML browser in OE just like Mozilla Firefox extension?
Oleg Chernavin 08/07/2007 05:00 am
Offline Explorer can easily download WAP sites. But its Internal browser is just MS Internet Explorer. So, I would suggest you to use FireFox after the download to view the site. You can right-click the downloaded Project and use Browse With menu. If FireFox is not there, select Configure Tools there and click AutoDetect, then OK button.

Best regards,
Oleg Chernavin
MP Staff
Kekmaklu 08/07/2007 10:55 pm
I already use Mozilla Firefox with WML browser support but still Offline Explorer cannot download the wap sites. any configuration need to be done?
Kekmaklu 08/09/2007 05:18 am
Seems like the program not good enough..i go through documentation also the same thing happen i still cannot download the WAP site http://chat.2wap.org
Oleg Chernavin 08/09/2007 02:20 pm
When I started to download it, it appeared to be a standard Web site. I had no problems with it at all.

Oleg.
Kekmaklu 08/09/2007 09:20 pm
The wap site have 2 website. One is standard wap forum which i can download it but another one is WAP chat site. This is the one that i couldn't download it. If you browse using Firefox with WML browser enable you will get the WAP chat site. If you disable the wml browser setting in firefox you will get wap forum. My only problem is the WAP chat site. Could you please help me on this? how am i going to download the WAP chat site.
Oleg Chernavin 08/10/2007 03:21 am
Yes, sure. But where is the link to tha WAP site?

Oleg.
Kekmaklu 08/12/2007 09:48 pm
The link to the wap site(if enable wml browser in Firefox) is chat.2wap.org - chat service. For normal website(without wml browser enable in firefox) is the same chat.2wap.org but the domain do forward to 2wap.org/forum . This is the problem i'm facing. I can only download the forum website but not the wap site chat service. I still have no idea how to download the wap site chat service.
Oleg Chernavin 08/13/2007 12:03 am
I see. What FireFox extension should I download to see it? I think, it is only necessary to change the User-Agent identification in the Options dialog.

Oleg.
Kekmaklu 08/14/2007 12:54 am
Thank you for reply. I think this is new challenge for offline explorer software which is facing two different website using same domain name.

You may download wmlbrowser addon at https://addons.mozilla.org/en-US/firefox/addon/62

you shall see the different of this website http://chat.2wap.org when you enable and disable wml browser. Only chat service wap site i having problem to download it. Hope you have an idea tweaking some setting in offline explorer. I still figure out on what you mention regarding on User Agent and will do testing on it.
Oleg Chernavin 08/14/2007 07:11 am
All you need is to add the following line to the URLs field of the Project:

Accept=text/xml,application/xml,application/xhtml+xml,text/html;q=0.9,text/plain;q=0.8,image/png,*/*;q=0.5,text/vnd.wap.wml;q=0.6

And the download will be as for WML browser.

Oleg.
Kekmaklu 08/14/2007 09:16 pm
Is the any different in User Agent setting between Offline Explorer Pro and Offline Explorer Enterprise(Trial)? I might want to upgrade to Enterprise Edition in the future, any setting should i do in Enterprise Edition?
Kekmaklu 08/14/2007 09:53 pm
I put below in Address(URLs). Is it correct?

UserAgent=Accept=text/xml,application/xml,application/xhtml+xml,text/html;q=0.9,text/plain;q=0.8,image/png,*/*;q=0.5,text/vnd.wap.wml;q=0.6
Kekmaklu 08/14/2007 09:54 pm
opsss..sorry i put like this

Accept=text/vnd.wap.wml,application/vnd.wap.wmlc

is it correct?
Kekmaklu 08/14/2007 09:57 pm
i got this error message

Download complete - 0 file(s)

Download complete. Status: 302 Object Moved

Kekmaklu 08/14/2007 10:19 pm
OK. I manage to download the wap site using below setting in URLs field:

http://chat.2wap.org/
UserAgent=Offline Explorer
Accept=text/xml,application/xml,application/xhtml+xml,text/html;q=0.9,text/plain;q=0.8,image/png,*/*;q=0.5,text/vnd.wap.wml;q=0.6

the weird thing is only 4 files

1) index.php
2) default.htm
3) logo.gif
4) Descr.WD3

I believe it should have more than that..
Oleg Chernavin 08/15/2007 01:51 am
I found out that User Agent doesn't matter here. The Accept= line is what forces the Web site to output WML content. The download is correct, because there is a Web form and no link to follow. You need to get some other starting URL of a page that has links to various pages and files.

Oleg.