problem running multiple instances of OE

Author Message
Stefan 09/29/2005 06:30 am
I set up a system where I have OE started from a batch file with the following call:

"C:\Program Files\Offline Explorer Pro\OE.exe" de/0 /CloseNoCountdown /Instance

Which works perfectly fine, however it does close any other instances of OE running at the time (seems to be randomly picking one to close down). I assume that is not intended behaviuor and it would be great to get a fix for that, since it makes it impossible to have several of these tasks running in parallel without one task killing of the others.

Thx

Stef
Oleg Chernavin 09/29/2005 06:53 am
Please use it the following way:

"C:\Program Files\Offline Explorer Pro\OE.exe" /Instance de/0 /CloseNoCountdown

The next version will be changed, so it will not matter whee this parameter is.

Best regards,
Oleg Chernavin
MP Staff
Stefan 09/29/2005 09:00 am
Thx for the tip, that solved the problem.

Stefan
Oleg Chernavin 09/29/2005 09:04 am
You are welcome!

Oleg.
Stefan 09/29/2005 04:41 pm
Something is still not 100% correct, I now had it happen again, that calling it up with the /Instance parameter took over a running OE instance instead of creating a new one ( I am now running the SR2 release from today). I would appreciate if you could take a look at the issue, since I was planning on deploying a larger number of parallel instances to aumotically run concurrent batches of download projects, but this will only work if I can be sure that each instance is really handeld seperately.

Thx

Stefan
Stefan 09/29/2005 04:44 pm
Actually it seems as if /Instance does not work any longer at all after moving to the latest OE version.

Stefan
Oleg Chernavin 09/30/2005 02:01 am
I fixed it:

http://www.metaproducts.com/download/opsetup.exe

Sorry for that!

Oleg.
Stefan 09/30/2005 03:51 am
Thx a lot

Stefan
Oleg Chernavin 09/30/2005 04:13 am
Does it work well now?

Oleg.
Stefan 09/30/2005 04:37 am
I have now installed it on the machine where I run these parallel instances and will watch it over the next hour to see if everything is being kept in order.

Stefan
Stefan 09/30/2005 04:59 am
I have it running now for the last 40 minutes and it seems to work as it should. Right now I am running 4 instances of OE at the same time, will up this to about 10. Should there be any more problems then I`ll let you know.

Thanks

Stefan
Oleg Chernavin 09/30/2005 06:04 am
OK. Good.

Oleg.