regressions: connection limit, media only downloads

Author Message
NG 08/21/2005 11:10 pm
The most recent version seems to have a couple of regressions.

1. Limiting connections by project no longer appears possible from the right click context menu in the download queue. It`s simply no longer listed as an option.

2. A couple of projects that I have that simply download images from sites stopped working correctly. They started throwing the following:

Error reading from file: [full path to where page file WOULD be if downloaded locally] Error code=00000003 Path not found

Enabling the downloading of pages as well gets things moving, but it shouldn`t be necessary.

This doesn`t affect all projects, some still work fine. I will try and narrow down the differences and see if there is a pattern.


This isn`t a regression, but something I find frustrating. I want the status panel across the bottom, and the upper half of the screen split in two -- project/queue panel on the left, log panel on the right. I don`t want to see the internal browser. I can dock the log panel to the bottom and it sits side-by-side with the status panel. I can also dock it to the internal browser which appears on the right side, but I can`t get the internal browser itself to disappear -- making it as small as possible is the best I can do, but it`s impossible to hide. Is there any way that you might be able to offer this kind of layout?

Finally, I`ve seen rumblings of Firefox cookie usage being implemented. Is there a timing on this for OEP?

Thanks,
NG
Oleg Chernavin 08/22/2005 04:02 am
I fixed the 1st issue. Thank you!

Can you please tell me the log line with that error? Maybe the path is weird or something like that.

Regarding the Internal browser - you can hide it in the View menu | Explorer Bars.

Best regards,
Oleg Chernavin
MP Staff
NG 08/22/2005 10:28 am
> I fixed the 1st issue. Thank you!

Great.

> > Can you please tell me the log line with that error? Maybe the path is weird or something like that.

It appears to be adding ".primary" to the end of the file name. If I have it save the text files, the ".primary" extension is not on the end of the saved files.

> > Regarding the Internal browser - you can hide it in the View menu | Explorer Bars.

Yes, but docking the log panel to the internal browser is the only way to have the log panel appear in the upper half of the screen to the right of the project window. Looking for this kind of layout:

1 2
333

where 1 is the project/queue panel, 2 is the log panel and 3 is the status panel.

NG 08/22/2005 10:39 am
Oleg,

Additionally, I`ve seen the following appear in the log panel in another project:

Error reading from file: Error code=00000003 Path not found

As you can see, no file name listed. Again, this is not in the same project as the others throwing the error mentioned earlier, but might be relevant while you`re working in that part of the code.
n/a 08/22/2005 11:38 am
I get some of these error messages also:

Error reading from file: Error code=00000003 Path not found

Would be nice to see what the problem exactly is, what file is the problem
Oleg Chernavin 08/23/2005 04:34 am
But can you please copy some of these lines from the Log and provide me with them?

Oleg.
NG 08/27/2005 02:07 pm
> But can you please copy some of these lines from the Log and provide me with them?

Here are a couple, along with their corresponding request lines:

HTTP18: Download complete. Status: 200 OK. URL: http://gallery.purehotmodels.com/2005/view_photo.php?set_albumName=album88&id=DSC_0153
HTTP19: Download complete. Status: 200 OK. URL: http://gallery.purehotmodels.com/2005/view_photo.php?set_albumName=album88&id=DSC_0165
Error reading from file: c:\download\gallery.purehotmodels.com\2005\view_photo.php@set_albumName=album88&id=DSC_0153.primary Error code=00000003 Path not found
Error reading from file: c:\download\gallery.purehotmodels.com\2005\view_photo.php@set_albumName=album88&id=DSC_0165.primary Error code=00000003 Path not found
Oleg Chernavin 08/27/2005 02:56 pm
I think I know what is wrong. The c:\download\gallery.purehotmodels.com\2005\ directory contains too many files already and Windows cannot place any more files there. To solve that please clean that folder and enable the directory overload protection in the Options dialog of Offline Explorer Pro | File Locations section.

Oleg.
NG 08/27/2005 03:05 pm
Actually that directory is empty when the download begins, so that`s not a likely solution.
Oleg Chernavin 08/27/2005 03:18 pm
Can you please help me to reproduce and fix the problem? Please send me an E-mail to support@metaproducts.com about that and include the Project settings - select the Project, click the Copy button on toolbar and then paste it to the message. if the site is password-protectedm please also let me know username and password.

Thank you!

Oleg.
NG 08/27/2005 04:21 pm
> Can you please help me to reproduce and fix the problem? Please send me an E-mail to support@metaproducts.com about that and include the Project settings

Sure. Done.
Oleg Chernavin 08/30/2005 08:41 am
Thank you! Got that message and I already reproduced the bug. I will work on it now.

Oleg.