Initial Pages With POP-ups do not are opened

Author Message
Kha 06/05/2005 06:12 am
Hi.

I have tested this:

After exporting downloaded sites, the link in the auto generated contents.htm file does not work for sites with the first page opening pop-ups if, and only if, the "about:internet" part is in the <!-- saved from url=(0014)about:internet --> line of the contents.htm file.

After removing the "about:internet" part in the contents.htm file, the links of the contents.htm file are working fine for both, root pages opening pop-ups and root pages do not opening pop-ups.

Some idea about this x-file?

Thank you very much.

Just for your information:
S.O.: Windows XP SP2
Offline Explorer Pro: 3.6.1930 release

Export parameters:
Put files to: The above directory
File names format: JOLIET CD-R 64
Use standard extensions: yes
Preserve online links: yes
Add original URL: yes
Create contents file: Yes (without customization, default layout)
All other options: off
Kha 06/05/2005 06:20 am
When i say pages with pop-ups, i mean pages with active content blocked by Internet Explorer 6 (the yellow top warning message in IE).

Sorry the inconvenience.
Kha 06/05/2005 07:31 am
You are adding this <!-- saved from url=(0014)about:internet --> remark to bypass the local zone restriction of Windows XP SP2, but i have seen you are not adding this remark or the remark <!-- saved from url=([string size])[URL] -->to all downloaded pages and this is the problem.

If you add the local zone bypass remark to the contents.htm file only links from contents.htm to pages with the corresponding local zone bypass remark will work. I mean, with the remark added to contents.htm, links to pages with no remark inside them, will not work.

According to Microsoft, the remark must be added right before the <html> tag and you are adding this remark just after. I have seen pages with two <html> tags too, one before the remark and other the corresponding to the page source.
Oleg Chernavin 06/06/2005 04:34 am
You can uncheck the Add Original URLs box in the Export dialog to export files without this comment. This should help.

Best regards,
Oleg Chernavin
MP Staff
Kha 06/06/2005 06:42 am
> You can uncheck the Add Original URLs box in the Export dialog to export files without this comment. This should help.
> > Best regards,
> Oleg Chernavin
> MP Staff

Yes Oleg, thank you very much, but if no comment is included in pages with active content, the locked active content warning will be displayed by IE. This would be a not desired behaviour of downloaded content. The problem is happening when we are exporting more than a project (site).

In this export session, there are sites with active content pages and there are sites with pages without active content, all mixed-up. If the save original URL flag is not set, there will be no pages with the about internet comment and pages with active content will show the yellow locked active content warning message in IE.

If the save original URL flag is set, pages with active content will display no warning, but, the comment will be included inside the contents.htm file too and links to pages without the comment will not open in IE.

I don`t know when OE Pro includes the comment or the right condition to include the comment but there are times OE Pro is including the comment in the contents.htm file and not is including the comment in some exported pages and this is the problem really.

Like rule of thumb, if OE Pro includes the about internet comment in the contents.htm file, ALL exported pages (having active content or not) must include the comment too.

Thank you very much Oleg.
Oleg Chernavin 06/06/2005 07:29 am
If the Original URLs box is checked, all pages - including contents.htm file will include that comment.

Oleg.
Kha 06/06/2005 12:08 pm
> If the Original URLs box is checked, all pages - including contents.htm file will include that comment.
>
> Oleg.

Thank you for the clarification Oleg. I will need research more deeply all this, because in some of our downloaded projects, there was pages without the comment and i think the Original URLs checkbox was checked. If i find something i will post here.

Thank you.
Oleg Chernavin 06/07/2005 02:20 am
Offline Explorer adds the comment to HTML pages only. So, if you find an HTML without the comment, let me know. I will improve the check.

Oleg.