Why has OEP deleted all of my Projects?

Author Message
Matthew 12/18/2004 12:36 pm
I had OEP running continuously for about five days downloading around 50Gb of data. At the end of the download, the queue contained only two files which seemed to cause OEP to get stuck in a cycle.

I suspended the queue to disk and closed OEP as usual. When I next started OEP, there are NO projects listed!! They have all gone :o( That is a disaster...

I keep OEP projects, maps and templates in a directory separate from the OEP program directory. This is purely to keep data and programs separate. Excluding .map files, here`s the contents of the projects directory:

18/12/2004 17:31 0 sequence.dat
15/12/2004 21:48 8,715 Template.bk1
15/12/2004 17:29 8,715 Template.bk2
15/12/2004 20:14 8,715 Template.bk3
18/12/2004 17:31 8,715 Template.dat
18/12/2004 17:31 0 Undo.dat
15/12/2004 07:25 110,144 URL2s.BLB
15/12/2004 07:25 147,193 URL2s.DAT
15/12/2004 07:25 61,440 URL2s.IDX
15/12/2004 07:25 110,144 URLs.BLB
15/12/2004 07:25 147,193 URLs.DAT
15/12/2004 07:25 61,440 URLs.IDX
18/12/2004 17:26 122 WebDown.bak
15/12/2004 20:18 122 WebDown.bk1
15/12/2004 17:24 139,014 WebDown.bk2
15/12/2004 14:14 139,010 WebDown.bk3
12/12/2004 11:02 137,756 WebDown.bw1
13/12/2004 00:03 139,018 WebDown.bw2
14/12/2004 00:04 139,003 WebDown.bw3
15/12/2004 00:04 139,009 WebDown.bw4
02/12/2004 21:35 135,021 WebDown.bw5
19/11/2004 00:01 126,565 WebDown.bw6
18/12/2004 17:13 122 WebDown.bw7
18/12/2004 17:31 122 WebDown.dat

I immediately took a backup of the projects directory just in case anything was salvageable. The files appear intact and of a size which indicates that they contain data, yet OEP behaves as if they do not exist. The project, maps and templates path in Tools --> Options is correct.

Why did OEP trash the projects and how can I get them back?
Matthew 12/19/2004 06:48 pm
I restored the projects list by following Oleg`s instructions given in this thread:
http://www.metaproducts.com/mp/mpSupport_User_Forums_Message.asp?id=9008

However, I would still like to know why the problem occured in the first place!
Oleg Chernavin 12/20/2004 06:51 am
This is strange to me too. It happens quite rarely and I cannot still reproduce it to find out what goes wrong. I will try to add more code checks to prevent this from happening.

Best regards,
Oleg Chernavin
MP Staff