Title attribute on 2 lines

Author Message
Daniel Lacroix 12/17/2004 12:29 pm
Did you know that if a title attribute in the <a> element span on 2 lines OE would not download the link.

Try downloading this folder http://www.tbs-sct.gc.ca/frc-cfr/default.asp.
The french page sidebar has 3 links with title attributes that span 2 lines.

Thanks,

Daniel.
Oleg Chernavin 12/17/2004 01:09 pm
Thank you! I just fixed it. Do you need the updated version now?

Best regards,
Oleg Chernavin
MP Staff
Daniel Lacroix 12/17/2004 01:12 pm
OK. It would be nice to have.

Thanks for the prompt service.

Daniel.
Oleg Chernavin 12/17/2004 01:27 pm
Here is the updated oe.exe file:

http://www.metaproducts.com/download/betas/oep1890.zip

Oleg.
Daniel Lacroix 12/20/2004 11:34 am
Hi Oleg,

The issue discussed here
http://www.metaproducts.com/mp/mpSupport_User_Forums_Message.asp?id=5384
is now occuring again.

Then, I tried to unclick the Add original URL to HTML files options from the Export menu but it doesn`t stay unclick, when you go back in. What is the default when doing the autoexport?

Daniel.
Oleg Chernavin 12/20/2004 11:47 am
The Export dialog parameters will be taken from the currently selected Project if it contains the Additional=AutoExport line. There was a problem that the "Add original URL" option could not be specified in that command. I just fixed that. The option will correspond to the last tenth digit in that line now.

Here is the updated version:

http://www.metaproducts.com/download/betas/oep1893.zip

Oleg.
Daniel Lacroix 12/20/2004 12:15 pm
Thanks. I will give it a try.
Oleg Chernavin 12/20/2004 12:20 pm
Yes, please keep me informed.

Oleg.
Daniel Lacroix 12/21/2004 10:29 am
Hi Oleg,

In the Project Properties, the Address(URL) I am using looks like this:
http://www.cio-dpi.gc.ca/default.asp
Additional=AutoExport=c:\webs\;101;DeleteProjectFiles

The saved from url= comment line was not written to the exported file but the <HTML> tag was ...
Can you have a look.

Thanks.
Oleg Chernavin 12/21/2004 10:49 am
Yes, HTML tag will be added, if <HTML> is not the first tag on the page. We discovered that MS IE sometimes displays HTML code instead of Web page when browsing from disk. This occurs with pages where first tag is not <HTML>.

But is it a problem for you?

Oleg.
Daniel Lacroix 12/21/2004 11:26 am
Our web pages starts like this:
<!-- RESOURCEID = 123 -->
<!DOCTYPE declaration.

I am only getting the <!-- saved from url= comment line on selected pages (pages which contains redirects). These are starting with the <!DOCTYPE declaration.

Could it be possible that if the page starts with a comment line the <!-- saved from url= line is not written to the exported file ...

Since I am disabling the save Original URL to HTML option, the extra <HTML> tag should not be written to it.

I am using OEP to download web pages to check for page validation. The pages that gets downloaded should be exactly what a user would get.

Thanks,
Daniel.
Oleg Chernavin 12/21/2004 11:30 am
I see. In fact, most users need that <HTML> tag, but your purpose is quite specific. What if I would add some Registry setting that will disable adding the tag? This way, all other users will have export as usually and you will be able to setup Offline Explorer the way you want.

Would it work for you?

Oleg.
Daniel Lacroix 12/21/2004 11:47 am
That would work.

Daniel.
Oleg Chernavin 12/21/2004 12:36 pm
OK. Registry key:

HKEY_CURRENT_USER\Software\Metaproducts\Offline Explorer Pro\Parameters

Create a DWORD value:
SkipHTMLOnExport

Set it to 1

Download the updated oe.exe file:

http://www.metaproducts.com/download/betas/oep1895.zip

Replace the old oe.exe file with it and now Export should not add <HTML> tag itself.

Oleg.
Daniel Lacroix 12/21/2004 02:04 pm
Oleg,

I am still getting the <HTML> tag on the first line after implementing the registry key and the new executable.

Daniel.
Oleg Chernavin 12/22/2004 07:39 am
I am sorry - I was in a hurry and didn`t test it properly. The following should work:

http://www.metaproducts.com/download/betas/oep1896.zip

Oleg.
Daniel Lacroix 12/22/2004 11:55 am
Thank you. It works.

Daniel
Oleg Chernavin 12/23/2004 05:51 am
Great!

Oleg.
Defenestration 12/23/2004 10:14 am
FYI, version info still shows build 1890 for oep1896.zip.
Oleg Chernavin 12/23/2004 10:33 am
Do you mean the version in the About box?

Oleg.
Defenestration 12/23/2004 04:03 pm
Yes, and also when you right-click the OE.exe file in Explorer and look at the properties.
Oleg Chernavin 12/24/2004 02:59 am
Perhaps, you downloaded a wrong version. I will upload it again today later.

Oleg.
Daniel Lacroix 12/24/2004 11:30 am
My version says 1896.
Defenestration 12/24/2004 07:56 pm
> My version says 1896.

I`m sorry, but Father Christmas hasn`t made a visit to my chimney on this evening:o( I`ve tried downloading with both Firefox and Avant Browser and no matter what I do I end up with OE Pro 3.5.1890, not 3.5.3896:o(.

Maybe I`ve been a naughty boy and I`m being punished for it, but I`m losing my religion, and here`s me thinking forgiveness was in the Christian belief! Oh well..............
Defenestration 12/24/2004 08:00 pm
I must have had too much sherry...., I meant ....., not 3.5.1.5.1896:o)!

Maybe I need to be a muslim to get it.... Asalam O` Alikum! Walikum Asilum!

Where is it!!!!!!
Oleg Chernavin 12/27/2004 03:29 am
Can you try to download the link again?

http://www.metaproducts.com/download/betas/oep1896.zip

Oleg.
Defenestration 12/27/2004 07:05 pm
I`ve re-downloaded oep1896.zip and also oep1898.zip and both of them show the version as being build 1890.
Oleg Chernavin 12/28/2004 05:00 am
Can you delete that file with the build 1890 and then unzip the new file?

Oleg.
Defenestration 12/28/2004 01:43 pm
Problem solved. I was runnning under a Limited account which did not have sufficient privileges to overwrite the OE executable. The application I was using did not give me an error message and so I thought the copy was successful, when in fact it wasn`t.

It`s now reading build 1898.

Sorry for wasting your time Oleg!
Oleg Chernavin 12/29/2004 03:03 am
No problem with that. I am glad that the problem is solved.

Oleg.