Need help downloading mms:// *.wmv files

Author Message
Noah 09/12/2004 04:47 am
I am trying to download streaming video (wmv) with a URL type of mms://
When I click "Download" it adds the following to the end of the URL:

?MSWMExt&MSWMExt&

The MSWExt& pattern is continued many times.

It is a password protected site, so I select the Logon ID/password option in the Properties screen.

At the bottom of the screen, it never connects.

Maybe it is a configuration issue, but I cannot figure it out.

Noah
Oleg Chernavin 09/13/2004 07:46 am
Can you please write me to support@metaproducts.com and tell me the site URL and the username/password to test Offline Explorer Pro? I will try to see what goes wrong there.

Thank you!

Best regards,
Oleg Chernavin
MP Staff
Geoffrey Spencer 09/18/2004 04:10 pm
Maybe I can help out. I have downloaded WMV, RTSP and others before. Do not assume that the link that you are seeing always points directly to the video file. Many sites now use server-side scripts to generate dynamic webpages and some even to re-direct you to the video you are looking for. The re-direction is to prevent people from downloading their video files. Some are even protecting their video files directly such that you can only play the files for a few hours or days until you are locked out. This I hate feature but there is no solution to this.

Now I am noticing something new. Many sites are protecting the videos from being downloaded by adding "gibberish" to the end of the video file link name. This "gibberish" must be there in order to get into the folder where the file is on the network. Treat the "gibberish" as an unlock key. The "gibberish" changes every so often to make downloading of a page difficult. I have to manually add one video at a time after each download because the page refreshes (new "gibberish") between downloading of the videos on a single webpage. Now I have a possible solution for you. It works for me. Use "Url Substitution".

Say you are downloading this:
http://www.server.com/video/video1.wmv?gibberish

Use this rule but uncheck it!!! (in other word the rule applies AFTER downloading):
URL: */video/*.wmv?*
Replace: .wmv?*
With: .wmv

It works for me but you have to read the page source to figure out what you can do.

Best of luck.


> Can you please write me to support@metaproducts.com and tell me the site URL and the username/password to test Offline Explorer Pro? I will try to see what goes wrong there.
> > Thank you!
> > Best regards,
> Oleg Chernavin
> MP Staff