Stability problems causing OE to "hang"

Author Message
Defenestration 06/19/2004 07:49 pm
I`ve been experiencing some stability problems which causes OE Pro to "hang". All other internet traffic is also blocked.

It occurred when I clicked on the Map tab while I was downloading the whole of the MetaProducts Users Forum. The download process stopped while the treeview map of the project was being expanded (I thought OE was fully multi-threaded so this should not happen?!). After the map had expanded the download did not continue and all internet traffic was blocked.

I had previously suspended it to file a couple of times.

Whenever OE "hangs" it is not possible to terminate the OE process using task manager, and so a reboot is always required. Why is this ? What`s stopping it from terminating ?
Oleg Chernavin 06/21/2004 07:03 am
Is it the same problem that you described later (an issue with the Internal HTTP server)?

Best regards,
Oleg Chernavin
MP Staff
Defenestration 06/21/2004 04:55 pm
> Is it the same problem that you described later (an issue with the Internal HTTP server)?
>

No. If a download is in progress and you select the map tab which contains a lot of entries, then while OE is expanding the map treeview the download stops. After the map treeview has been expanded OE sometimes will start the download again. Sometimes it just hangs.

Why can`t OE expand the map treeview in a separate thread, so a download will not stop during the expansion ?
Oleg Chernavin 06/21/2004 05:03 pm
OK. I will need to work on this. Thank you!

Oleg.