Help with unique form

Author Message
Steve Sieloff 06/03/2004 05:44 pm
Oleg --

I am not sure OE Pro can help here ... this site takes a general search term (like A for the last name) and returns a result page with a pick list of 905 Notaries -- by clisking on any 1 entry in the box you can get detailed information returned about that Notary.

http://www.sec.state.vt.us/seek/not_seek.htm

I tried setting on the Advanced Option of Explore HTML forms as well as trying the Evaluate Script Navigations ... all I get is the first page fetch downloaded and nothing else.

Here is my project settings ... please let me know what you suggest!

[Object]
OEVersion=Pro 3.2.0.1708
Type=0
IID=7010
Caption=http://cgi.sec.state.vt.us/cgi-shl/nhayer.exe
URL=http://cgi.sec.state.vt.us/cgi-shl/nhayer.exePOST=form_id=NOTARY&NOTLNAME=a&notfname=IgnoreLogOutLinksAdditional=ConvertPOSTToFileNameReferer=http://www.sec.state.vt.us/seek/not_seek.htmSetCookie=MyName=Nicko; cookie_id=_193114JAV
Lev=1000001
Weekday=257
LimTSize=10000
LimNumber=5000
LimTime=100
EnableForms=True
FTText.Exts=htmlhtmaspjspstmstmlidcshtmlhtxtxttextxspxmlrxmlcfm
FTImages.Exts=gifjpgjpegtiftiffxbmfifbmppngipxjp2j2cj2k
FTVideo.Exts=mpgavianimpegmovfliflcvivrmrvasfasxwmvm1vm2vvob
FTAudio.Exts=wavriffmp3midmp2m3uravocwma
FTArchive.Exts=ziparcgzzarjlhalayleirarcabtarpakacejar
FTUDef.Exts=jscssssivbsdtd
FTText.B=oooooo
FTImages.B=xooooo
FTVideo.B=xooooo
FTAudio.B=xooooo
FTArchive.B=xooooo
FTUDef.B=oooooo
FTOther.B=oooooo
FTSizes=0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0
RPathBx=1
LastStart=168:126:144:64:183:159:226:64:
LastEnd=224:12:116:65:183:159:226:64:
S200=1
SPar=1
SSav=1
SLast=200
SSiz=39048
SMdf=1
LFiles=1
LSize=39048
Flags=1
ImgDim=0,0,0,0
PrevURL=http://cgi.sec.state.vt.us/cgi-shl/nhayer.exe
ParseComplexScripts=True
Oleg Chernavin 06/04/2004 11:07 am
Steve,

The page didn`t have the form closing tag and this confused Offline Explorer Pro. I just improved the code. Here is the updated version:

http://www.metaproducts.com/download/betas/oep1713.zip

Best regards,
Oleg Chernavin
MP Staff
Steve Sieloff 06/04/2004 04:24 pm
Oleg --

Thanks for the quick response!

The new release did indeed put the 905 drop down links into the queue ... that`s the good news.

The bad nes is that OE Pro then "hangs" trying to download the second file from the queue ... I let it sit for 20 minutes in the "Downloading" mode but it never cam back with a file/page for parsing.

Any ideas on what I am doing wrong?

Steve

> Steve,
>
> The page didn`t have the form closing tag and this confused Offline Explorer Pro. I just improved the code. Here is the updated version:
>
> http://www.metaproducts.com/download/betas/oep1713.zip
>
> Best regards,
> Oleg Chernavin
> MP Staff
Oleg Chernavin 06/05/2004 08:52 am
Steve,

I am at home now and I can`t check it myself. But try this idea - use number of connections = 1 in the Options dialog for this download. The server might be confused by so many accesses to the database.

Oleg.
Steve Sieloff 06/05/2004 01:15 pm
OLeg --

I tried setting connections=1 and even set a delay of 1 second betweeen downloads but still did not download any additional files ... queue still show 909 files to download ... I think the cookie information is not helping any as it appears to change between manual downloads (at least that`s what I see when surfing manually under IE but I could be wrong) ... have a good weekend and let me know what you find/suggest when you get back into the office -- this is not a high priority download for me!

Thanks for your continued AWESOME support!

Steve

> Steve,
>
> I am at home now and I can`t check it myself. But try this idea - use number of connections = 1 in the Options dialog for this download. The server might be confused by so many accesses to the database.
>
> Oleg.
Oleg Chernavin 06/07/2004 09:37 am
Steve,

I have found out that OE submits some form parameters incorrectly. This is not critical for most sites, but that one hanged for a long time. I fixed that. Here is the update:

http://www.metaproducts.com/download/betas/oep1714.zip

Oleg.
Steve Sieloff 06/07/2004 01:52 pm
Oleg --

Your product is only over shadowed by your AWESOME support!!!!

The latest fix works great ... all downloads are moving thru the queue ... a little slow but I think it is a function of the target server and not OE Pro ... thanks!!!!

Steve

> Steve,
>
> I have found out that OE submits some form parameters incorrectly. This is not critical for most sites, but that one hanged for a long time. I fixed that. Here is the update:
>
> http://www.metaproducts.com/download/betas/oep1714.zip
>
> Oleg.
Oleg Chernavin 06/08/2004 01:51 am
Good!

I noticed that the server has temporary slowdowns from time-to-time. Perhaps, it is loaded quite well and the database is not that fast.

Oleg.