Confused - OE perfect in OE browser but not in Export

Author Message
Jim Chavez 04/14/2004 02:23 pm
Hi, I am evaluating OE Explorer Pro and if I can get it to work, will purchase ASAP. In the OE Explorer browser my project looks great...I can click through all the pages that are downloaded and I`m feeling great. However, when I export for CD, select the Joliet file extensions and rip the CD, a bunch of the pages do not show up. Is there a trick to this?

Thanks...
Oleg Chernavin 04/14/2004 02:33 pm
Yes, this happens sometimes, because Offline Explorer contains internal Web server that emulates online environment when you browse downloaded sites offline.

On the other hand, not all links work fine when a browser loads pages directly from your disk.

Anyway, can you please tell me which site you are downloading and which links on which pages do not work correctly from CD. I will do my best to help you.

Best regards,
Oleg Chernavin
MP Staff
Jim Chavez 04/14/2004 04:21 pm
The website is www.agilent.com/find/ad The resolved URL is
http://we.home.agilent.com/cgi-bin/bvpub/agilent/Industry/cp_Industry.jsp?NAV_ID=-14257.0.00&LANGUAGE_CODE=eng&COUNTRY_CODE=US

I have gone through and individually downloaded the site that I want. An example of a path that does not work is if you click on the Satellite Communications link (works fine), then the PSA Series Spectrum Analyzer link (does not work)....however the links above it do (89600 Series Vector Analyzer)

Thanks for any help you can give.
Jim Chavez 04/14/2004 04:36 pm
One additional piece of info I just found out is that there appears to be a redirection that takes place, but then resolves to the correct page. It is a 302 redirect. Is there a way to go to the correct resolved page and add it to the project individually so that the page will exist in the project and then I can go into my Web editor tool and change the URL to point to the downloaded page?
Oleg Chernavin 04/15/2004 03:29 pm
I just loaded and exported a part of the Web site with these links. The exported copy worked well. Offline Explorer processes all redirects and changes them with real links during the export.

I don`t know what happened in your case, but there is an easy way to overcome the problem.

Please download the following file:

http://www.metaproducts.com/download/betas/oebrowse.zip

Unzip the file to the directory where Offline Explorer is installed and make the Export to a Compressed EXE Viewer. This should fix all such problems.

Please let me know if this way works for you.

Oleg.
Nancy Rucinski 05/07/2004 08:45 pm
I am having the exact same problem as Mr. Chavez. I just tried the fix you recommended and it did not work for me. I would also like to purchase OE Pro if I could only get it to work. The site I am trying to download is http://ww2.kingarthurflour.com/cgibin/htmlos.cgi/0397.1.692129826721650954.
Oleg Chernavin 05/08/2004 03:09 pm
Can you please tell me which links on that page do not work after the export?

Thank you!

Oleg.
Nancy Rucinski 05/08/2004 08:44 pm
I just went back to the web site and this time the address is http://ww2.kingarthurflour.com/cgibin/htmlos.cgi/5432.1.586055621778769528
It should say "Recipes from the King Arthur Kitchen" at the top. I set OE to download 2 levels and when I view the download offline you can click on "browse all these recipes" and a list of recipe names appears. You can then click on a recipe name and the recipe appears. When I export this projet and then burn the CD all the CD will produce is the first page. Any attempt to go further gets a dialog box telling me I must go online to view these files. Thanks for your help.


Can you please tell me which links on that page do not work after the export?
>
> Thank you!
>
> Oleg.
Oleg Chernavin 05/09/2004 03:32 pm
I am sorry, but browsing the site involves the form which cannot be loaded by Offline Explorer yet because the form contains the editable field and Offline Explorer cannot fill that field automatically.

We will work on the solution, but I am not sure how much time it may take.

Oleg.
Nancy Rucinski 05/10/2004 08:08 am
thank you for your reply. At least now I know it`s not my fault and I can quit wasting blank CDs. I will continue to try other sites.

> I am sorry, but browsing the site involves the form which cannot be loaded by Offline Explorer yet because the form contains the editable field and Offline Explorer cannot fill that field automatically.
>
> We will work on the solution, but I am not sure how much time it may take.
>
> Oleg.
Oleg Chernavin 05/10/2004 02:17 pm
Yes, let me know if you face any otehr problem - I will try to be more helpful!

Regarding blank CDs - I would suggest you to check the exported files first - if they work from your hard disk, they will work from a CD.

Oleg.