Bug in URL Substitute

Author Message
henry Bai 03/22/2004 03:30 am
HI! There seems to be a bugi n your URL Substitute..
In the URL, I put http://www.easypooltutor.com/article*
Repleace I put -m.htmlnested&order=0&thold=0
With I put .html

When I download from the site, all the files including the http://www.easypooltutor.com/article95-m.htmlnested&order=0&thold=0 is downloaded..
Without changing any other option, I click on properties of the project, change to "Do not download existing Files" and put Additional=DeleteOldFiles

Then there seems to be 3 problems
1. The links http://www.easypooltutor.com/article220-m.htmlnested&order=0&thold=0 from http://www.easypooltutor.com/article-topic-12.html are NOT updated to http://www.easypooltutor.com/article220.html as specified in the URL Substitute.
2. However, the files article220-m.htmlnested&order=0&thold=0 are already deleted from my local harddisk..
3. The maps are not updated when the files are deleted. Themap is only updaetd after I restart OE.

Thanks
Oleg Chernavin 03/22/2004 12:10 pm
I am trying to reproduce the problem. I went to:

http://www.easypooltutor.com/article-topic-12.html

And what I find is that all links to article are:

http://www.easypooltutor.com/article105.html
http://www.easypooltutor.com/article108.html
http://www.easypooltutor.com/article14.html
http://www.easypooltutor.com/article220.html
http://www.easypooltutor.com/article95.html
http://www.easypooltutor.com/article96.html

and so on.

And I can`t find any link like:

http://www.easypooltutor.com/article95-m.htmlnested&order=0&thold=0

What`s wrong there?

Best regards,
Oleg Chernavin
MP Staff
henry Bai 03/22/2004 01:46 pm
hmm.. On http://www.easypooltutor.com/article-topic-12.html, pressing the Read more button leads me to http://www.easypooltutor.com/article220-m.htmlnested&order=0&thold=0

hmm. OK.. I get it.. You ahve to Login.. When I logout, it would lead me to the normal page...
Try to register an account and login
then try the page again
:)


> I am trying to reproduce the problem. I went to:
>
> http://www.easypooltutor.com/article-topic-12.html
>
> And what I find is that all links to article are:
>
> http://www.easypooltutor.com/article105.html
> http://www.easypooltutor.com/article108.html
> http://www.easypooltutor.com/article14.html
> http://www.easypooltutor.com/article220.html
> http://www.easypooltutor.com/article95.html
> http://www.easypooltutor.com/article96.html
>
> and so on.
>
> And I can`t find any link like:
>
> http://www.easypooltutor.com/article95-m.htmlnested&order=0&thold=0
>
> What`s wrong there?
>
> Best regards,
> Oleg Chernavin
> MP Staff
henry Bai 03/23/2004 03:16 am
Well, any luck with the trial?
Is the problem reproduced?



> hmm.. On http://www.easypooltutor.com/article-topic-12.html, pressing the Read more button leads me to http://www.easypooltutor.com/article220-m.htmlnested&order=0&thold=0
>
> hmm. OK.. I get it.. You ahve to Login.. When I logout, it would lead me to the normal page...
> Try to register an account and login
> then try the page again
> :)
>
>
> > I am trying to reproduce the problem. I went to:
> >
> > http://www.easypooltutor.com/article-topic-12.html
> >
> > And what I find is that all links to article are:
> >
> > http://www.easypooltutor.com/article105.html
> > http://www.easypooltutor.com/article108.html
> > http://www.easypooltutor.com/article14.html
> > http://www.easypooltutor.com/article220.html
> > http://www.easypooltutor.com/article95.html
> > http://www.easypooltutor.com/article96.html
> >
> > and so on.
> >
> > And I can`t find any link like:
> >
> > http://www.easypooltutor.com/article95-m.htmlnested&order=0&thold=0
> >
> > What`s wrong there?
> >
> > Best regards,
> > Oleg Chernavin
> > MP Staff
Oleg Chernavin 03/23/2004 10:37 am
Yes, I fixed several related problems. Please test the following updated oe.exe file:

http://www.metaproducts.com/download/betas/oep1540.zip

Let me know how it works.

Oleg.