Problem site - Can you help me out ?

Author Message
Andy Russell 03/16/2004 06:33 am
Hi ,

I`m trying to download this site: http://www.swiftleisure.com

OE Seems to have a problem with the products areas, for example if you click

PRODUCTS > ABBEY CARAVANS > then any Product range from the dropdown > then a model from the dropdown

at this last step it gives up and no matter what i can`t get it to download this ?

any ideas ?
Oleg Chernavin 03/16/2004 07:02 am
Please download the updated Offline Explorer Pro version here:

http://www.metaproducts.com/download/betas/oep1529.zip

Replace the old oe.exe file with the new one. Now you will be able to enable forms processing in the Project Properties dialog | Advanced section and load these links.

Best regards,
Oleg Chernavin
MP Staff
Andy Russell 03/16/2004 07:13 am
> Please download the updated Offline Explorer Pro version here:
>
> http://www.metaproducts.com/download/betas/oep1529.zip
>
> Replace the old oe.exe file with the new one. Now you will be able to enable forms processing in the Project Properties dialog | Advanced section and load these links.
>
> Best regards,
> Oleg Chernavin
> MP Staff


Hi oleg,

I`ve tried the new file but it hasn`t made any difference. Any other ideas ?
Oleg Chernavin 03/16/2004 08:44 am
OK. I just made few more improvements.

Here is the updated file:

http://www.metaproducts.com/download/betas/oep1532.zip

I would also ask you to add the following line to the URLs field:

Additional=ConvertPOSTToFileName

This will make correct filenames for all downloaded HTML form results.

Oleg.
Andy Russell 03/17/2004 04:47 am
Hi oleg,

Thanks - that did the trick - but it`s brought up another problem.

Although now the javascript links work when i`m looking at the site from the browser window within OE - once i export the site all the links stop working -

ie : in the browser window the link points to :
http://127.0.0.1:7000/Default/www.swiftleisure.com/s_pages/products/model.asp@brand=abbey&model=312&vanid=UKABAVEN312&vmflag=v&country=uk&range=AVENTURA@model=312&brand=abbey&country=uk&vmflag=v&range=AVENTURA

but once i export it that same link just goes to :
C:\Export\www.swiftleisure.com\s_pages\products\model.asp

It`s missing out all the extra part of the string, any ideas why this is happening on the export ?

> OK. I just made few more improvements.
>
> Here is the updated file:
>
> http://www.metaproducts.com/download/betas/oep1532.zip
>
> I would also ask you to add the following line to the URLs field:
>
> Additional=ConvertPOSTToFileName
>
> This will make correct filenames for all downloaded HTML form results.
>
> Oleg.
Oleg Chernavin 03/17/2004 05:23 am
Yes, the exported version will not work, because forms submissions require a server that processes the form. Offline Explorer uses its own internal server to overcome the problem.

Oleg.
Andy Russell 03/17/2004 05:43 am
> Yes, the exported version will not work, because forms submissions require a server that processes the form. Offline Explorer uses its own internal server to overcome the problem.
>
> Oleg.

Arrgh that`s a big problem for me :(

Does anyone know of any software that basically creates a webserver from an executable ? - i need to distribute a flat version of this site on cd, so the webserver built into OE isn`t much use to me...
Oleg Chernavin 03/17/2004 05:49 am
I think, I could do that quite quickly. Can you write me to support@metaproducts.com ? We will discuss it.

Oleg.
Andy Russell 03/17/2004 10:18 am
hi oleg,

i`ve emailed you :)
Oleg Chernavin 03/18/2004 03:43 am
Andy,

I still haven`t got your E-mail, so I used the address you used in the forum message and wrote you myself. Please reply that message.

Oleg.
Andy Russell 03/18/2004 05:38 am
emailed you again earlier today - hope you get it this time :)
Oleg Chernavin 03/18/2004 06:06 am
Yes, I got it. I hope to have some solution in few days. I will let you know when I have something to show.

Oleg.