Download hanging/slowing down after few seconds

Author Message
Mike 02/10/2004 11:41 am
I am downloading a news archive located at www.sexcriminals.com/news-archive/. Whenever I start the project, it loads a few pages than almost always slows down to where it downloads one file every 5 to 10 seconds. There does not appear to be latency on the site when I explore it with a browser.

It sounded like a maximum number of connections issue, so I set a delay on starting downloads of 2 seconds and limited the number of simultaneous connections to 6. No change. I don`t really know what the Speed controls do, but I tried low, medium and high with no difference noted.

Status seems to show OE spending most of its time connecting to host. A high percentage of the time it fails and has to retry. Like I said, about once every 5 to 10 secs a file gets through and is downloaded.

Any ideas?
Mike 02/10/2004 05:12 pm
FYI - I tried several other things from the forums archive which seem to have solved the problem. I limited the number of connections to (3) and set a random delay of 1-3 seconds. I then changed the proxy settings as you suggested last year for a parsing problem and it works well. Increasing the number of connections to more than (3) seemed to bring back the problem.

From archive:
"There is a setting that can help in such cases. Please open the Options dialog | Proxy | HTTP section. Select HTTP Proxy on top, make Address field empty and check the NTLM box below. Now click OK button and try to download files again."

> I am downloading a news archive located at www.sexcriminals.com/news-archive/. Whenever I start the project, it loads a few pages than almost always slows down to where it downloads one file every 5 to 10 seconds. There does not appear to be latency on the site when I explore it with a browser.
>
> It sounded like a maximum number of connections issue, so I set a delay on starting downloads of 2 seconds and limited the number of simultaneous connections to 6. No change. I don`t really know what the Speed controls do, but I tried low, medium and high with no difference noted.
>
> Status seems to show OE spending most of its time connecting to host. A high percentage of the time it fails and has to retry. Like I said, about once every 5 to 10 secs a file gets through and is downloaded.
>
> Any ideas?
Oleg Chernavin 02/11/2004 04:00 pm
Mike,

When you view sites in a browser, it downloads pages one-by-one, which corresponds to 1 connection in OE with few seconds delay.

I know that there are sites that restrict users activity with just few connections, so these two sites could be such case.

Can you please try to download other sites with 10 connections to see if it reproduces or not?

Thank you.

Best regards,
Oleg Chernavin
MP Staff