OE Pro keeps shutting down

Author Message
Tony 01/21/2004 04:07 am
Hi
I have been using OE Pro for years, very successfully.
I am now having problems, OE Pro fails after a few minutes running.
There are no error messages or log entries.
My system is:
Win2K Pro, SP4 with latest patches but not .net framework
Norton AV Enterprise, Black Ice firewall, Pest Patrol, all with current updates.
I have run a full scan with Norton and Pest Patrol, no problems
I have reinstalled Win2K SP4, deinstalled OE Pro, removed all directories & reinstalled, same problem.
I have upgraded OE Pro to latest version, same problem.
No changes have been made to the PC appart from the above regular updates.
Do you have any suggestions please
Oleg Chernavin 01/22/2004 07:57 am
We just fixed one problem that could be a reason of such crashes. Can you please download and unzip the following file:

http://www.metaproducts.com/download/betas/oep1480.zip

Replace the old oe.exe file with the new one.

Does this help?

Best regards,
Oleg Chernavin
MP Staff
Tony 01/22/2004 03:57 pm
Oleg

I am affraid not
OE ran for 8 minutes then crashed. Got this message from windows
"OE.exe has generated errors and will be closed by windows. You will need to restart the program"
Oleg Chernavin 01/23/2004 05:12 am
Does this happen with all Web sites you are downloading or just with some?

Oleg.
Tony 01/24/2004 06:18 pm
> Does this happen with all Web sites you are downloading or just with some?
>
> Oleg.

All sites
Oleg Chernavin 01/27/2004 04:00 am
Do you have enough free disk space on your hard disk?

Oleg.
Tony 01/27/2004 09:59 am
Oleg

Yes, about 100G free
Its an AMD 2000+ system with 1G of RAM
Oleg Chernavin 01/29/2004 05:54 am
We have just release the 3.0 version on our site. How does it behave? It contains few more fixes comparing with the previous version.

Oleg.
Tony 02/05/2004 03:44 am
Oleg.

I have upgraded to V3 - same results :-(
But, I have now had time for some serious experiments.

My system is a server running Win2K on a 600G RAID5 array, some 500G of which is the main data volume. This is where OE normally points for its download area. I have a cache volume where I point all the caches and temp files, this minimises fragmentation on the rest of the array, this is where the OE project folder lives. Plus system volumes and a spare volume of 10G - just in case :-)
The data volume now has some 420G of data on it out of the 500G capacity
All volumes are defragmented automatically by diskeeper.
OE in various versions has been running on this server for the last 2 + years.

If I point OE download at the spare volume it works perfectly, moving the project folder has no effect.
If I point it at the data volume it fails within 10 minutes, usually much quicker.
If I run OE on a workstation and point the download across the network at the shared data volume root it works perfectly.

I installed a clean copy of Win2K on the spare volume. Added SP4 + NIC drivers + video driver + OE V3 and nothing else. OE behaved exactly the same. I tried this with Pro and AS versions.

So, it looks like OE has an aversion to large disk volumes with lots of data on them ?

Any ideas please, appart from repartitioning the server :-)

thanks
Oleg Chernavin 02/06/2004 07:22 am
Tony,

Do you mean that when the Download Directory points to the large data volume, it fails. Or it fails when its Projects, Maps, templates directory is on the Data volume?

Oleg.
Tony 02/06/2004 09:54 am
> Oleg.

I havn`t tried just moving the projects directory to the data volume, but with the download directory on the data volume or with both directories on the data volume it fails.
willi_walter 02/06/2004 11:27 pm
Hi Tony,

have you look up the pages in Explorer or Navigator as source-text?
Some page are safty by manipulate the URL and by this doing OE can break down. :-(((

Greets
Willi
Oleg Chernavin 02/07/2004 05:26 am

> I havn`t tried just moving the projects directory to the data volume, but with the download directory on the data volume or with both directories on the data volume it fails.

Thank you! I will review the code carefully. I hope to have some results in a week.

Oleg.

Tony 02/07/2004 06:16 pm
Hi willi

No, thats not the problem, thanks.
I have found that lots of sites will translate their urls, you just have to start from OE`s brouser, get into the site then run the project starting somewhere deep inside and OE usually figures it all out.
Its something I do with my sites, but for practical reasons, not to inconvenience anyone.
I have never had a bad link crash OE though, confuse it yes, crash it no.
There is a good point about not using IE etc. at the same time as OE though. It does seem to be possible to detect this and refuse the second session.
Tony 02/11/2004 02:47 pm
Oleg.

Some more information for you
I have been experimenting again :-)

I had Task Manager running the whole time to check for memory leaks, there wern`t any and most of the time memory usage was so small as not to be noticable.

If I set max download file size to less than 1M, OE runs ok
If I set it to less than 2M, OE fails after five or six downloaded files
If I set it to unlimited, OE fails part way through the first big file.
I have rechecked cache space and fragmentation of all disks - ok

hope this helps a bit.
Oleg Chernavin 02/12/2004 03:21 am
Thank you for the details! They narrow the search range.

Can I ask you for more details? Can you please write me to support@metaproducts.com and send me your Project settings? I want to see what kind of files do you load to try to reproduce that behaviour.

Thanks again!

Oleg.
Heli Ammann 02/23/2004 07:21 am
Hy,

I have the same problem. My OE ist crashing one or two times a day; it seems that the error appears when exporting big sites (I make about 50 site-downloads every day).
When i tried to export it to a fast RAID5-Array, it crashed nearly every time. So I used again my old, normal, slow harddisk - now it works (in the most cases).
Maybe OE has problems with exporting to **fast** disks?
Oleg Chernavin 02/23/2004 08:58 am
Thank you for the info. I will check it as well.

Oleg.
Terje 07/14/2004 05:48 am
I think I have identified the problem. I experienced the same crashes within the first five minutes of usage of OEE. I use the newest version (3.2.17??)

It worked perfect for a while, but suddenly the program turned worthless. I tried every possible adjustment in the options, but nothing changed. Then I went into the directory of OEE. It contained all combined 1.4 gb files. Most of it was que-files and so forth. I deleted everything exept for the webdown and templatefiles. Now the program works as a dream, and has done so for about 2 hours....
Oleg Chernavin 07/14/2004 06:08 am
Thank you! Were all these files in the Queue subdirectory? Perhaps, I have to move more than 1000 URLs to each of these files. This will decrease the number of que*.tmp files in the directory.

These files appear when there are too many files in the queue. OE holds no more than 2000 URLs in memory. The rest are being saved to the temporary files and each file contains 1000 URLs. So, if you have 100,000 files in the Queue, there are 98 files in the directory.

Oleg.
Terje 08/10/2004 02:33 pm
Yes, as I remember most of them were in the Queue subdirectory. I have been running up to 300 000 files in the queue in several different projects, so there were a lot more than 98 of them. Pretty much, I just deleted every file I didn`t know that I really needed.

PS!! The program ran as a dream for a while, then started to crash again. I repeated the process above, and it works again flawless...
Oleg Chernavin 08/10/2004 03:12 pm
I made some changes in the recent version and it now cleans the Queue subdirectory more effective way automatically.

Here is the updated version:

http://www.metaproducts.com/download/betas/oep1775.zip

Oleg.
Tony 08/17/2004 02:57 pm
Oleg.

Because of the problems I had, I restructured my database and changed to Mass Downloader, not so convenient but it worked.

I have now recreated the original database, more or less, and tested the new version of OEP.
So far it has worked ok

thanks
Oleg Chernavin 08/18/2004 01:41 am
Good!

Oleg.