Problem Site -- http://store.sun.com/

Author Message
Gerald 11/10/2003 09:35 am
I`m not quite sure how to explain this one. If or when you have time, try mirroring the following site (or portion of): http://store.sun.com/

The problem I`m having is the resulting links may or may not take you to the intended offline content. I`ve had problems where the "Servers" link will take you to the "Spare Parts" page. Additionally, the servers link appears as:

http://store.sun.com/catalog/doc/BrowsePage.jhtml;$sessionid$MMZB2JZCXCZ3HAMTHLUSQCUBSM3OSKXO?catid=26829

In the offline content, links of this type appear to be the offending ones. One of three things occur: 1) The link functions and the proper content is displayed; 2) The link functions, but the wrong content is displayed; 3) The link is broken.

Modifying the link in the offline (and online content) to:

http://store.sun.com/catalog/doc/BrowsePage.jhtml?catid=26829

(actually the "?" is replaced by "@" in the offline content, but both characters work when viewing through the OEP web server).

Thanks,
Gerald
Gerald 11/10/2003 09:36 am
Additionally, pricing information on the products are not present in the offline content unless the actual product is the starting address of the project.

(i.e. http://store.sun.com/catalog/doc/BrowsePage.jhtml?cid=55844 )

Gerald
Gerald 11/17/2003 09:33 am
Has anyone had a chance to take a look at this problem? Is it a limitation of OEP? Is there a workaround that anyone knows about?
Oleg Chernavin 11/18/2003 11:05 am
I am sorry for the long delay answering. The problem is that the server cannot serve simultaneous requests properly. You can workaround this easily - open the Options dialog and change the Connections number to 1. Now you can start downloading the site again and all links will point to the proper information.

Best regards,
Oleg Chernavin
MP Staff
Gerald 11/20/2003 07:34 am
Thanks a million. I`ll give that a try.

Gerald
Oleg Chernavin 11/20/2003 10:37 am
You are welcome!

Oleg.