Javascript-generated Flash

Author Message
Gil Tayar 09/29/2003 09:48 pm
(BTW, thanks for the response on my previous question. I just noticed I didn`t respond with even a "thank you")

The problematic page is the following: http://www.xbox.com/en-us/default.htm, which I am downloading with level=0 (to download only this page), and with all File Filters set to "Load from any site").

What I get is that the swf (flash) is displayed, but is not downloaded (i.e. OE made the link point to the original site and did not download the flash). From the File filter settings it should have downloaded the file, but it didn`t.

Even though the <object> tag is generated via Javascript, I know that OE has recognized the link, as it has absolutized it (the source in the original page has just the path, and the OE-modified source has the whole URL). So why does it not download the file?

BTW, the relevant HTML fragment is:
<param id="..." name="movie" value="/NR/rdonlyres/.../pbvnflfever2004.swf?href=/en-us/nflfever2004/default.htm">

Thanks,
Gil
P.S. I am using OE Pro 2.9.1302 SR1
Oleg Chernavin 09/30/2003 08:18 am
Gil,

Most probably, OE was told not to load the file in either File Filters or URL Filters. I would suggest you to look in URL Filters | Directory. If it has selected "Load from the starting directory only", then change it to "Load from all directories" or (even better), add .swf extension to the File Filters | User Define and select "Load from any site" in the category Location box.

I hope this helps.

Best regards,
Oleg Chernavin
MetaProducts corp.
Gil Tayar 09/30/2003 09:07 am
> Gil,
> > Most probably, OE was told not to load the file in either File Filters or URL Filters. I would suggest you to look in URL Filters | Directory. If it has selected "Load from the starting directory only", then change it to "Load from all directories" or (even better), add .swf extension to the File Filters | User Define and select "Load from any site" in the category Location box.
> > I hope this helps.
> > Best regards,
> Oleg Chernavin
> MetaProducts corp.

Oleg,
I did all that. Moreover, to be sure, I disabled all filtering, setting everything I possibly can to "Load from all sites/directories/files/protocols...".

Same problem. Another thing - I believe (but am not 100% sure) in 2.8 I did _not_ have the problem.

Gil
Gil Tayar 09/30/2003 09:11 am
> Gil,
> > Most probably, OE was told not to load the file in either File Filters or URL Filters. I would suggest you to look in URL Filters | Directory. If it has selected "Load from the starting directory only", then change it to "Load from all directories" or (even better), add .swf extension to the File Filters | User Define and select "Load from any site" in the category Location box.
> > I hope this helps.
> > Best regards,
> Oleg Chernavin
> MetaProducts corp.

I did a recheck, and I believe I`ve found part of the problem. In the URL Filters/Directories, I had some excluded/included directories which were disabled (becase I set the radio box above to be "load files from all directories"). Because they are disabled, they should have no effect, but just to see, I removed all include/exclude filters. (and still set the radio button to be "load files from all directories".)

Result: OE now rewrites the swf URL to point to a local folder (which is better, as it seems it now recognizes it as something that it should download), but does not download the file (which is not good).

Gil
Oleg Chernavin 10/01/2003 03:23 am
Gil,

Can you please send me your Project to support@metaproducts.com ? Please select the Project, click Copy button on toolbar and then paste it to the E-mail message. I will see what is wrong there.

Oleg.
Gil Tayar 10/01/2003 10:55 am
> Gil,
> > Can you please send me your Project to support@metaproducts.com ? Please select the Project, click Copy button on toolbar and then paste it to the E-mail message. I will see what is wrong there.
> > Oleg.

On its way...
Oleg Chernavin 10/02/2003 04:58 am
OK. I will wait for it.

Oleg.
Gil Tayar 10/02/2003 08:52 am
> OK. I will wait for it.
> > Oleg.

Did you get it?

Gil
Oleg Chernavin 10/02/2003 10:10 am
Not yet. I just called our support department. They got no E-mail from you. Can you please try again?

Oleg.
Gil Tayar 10/02/2003 11:47 pm
> Not yet. I just called our support department. They got no E-mail from you. Can you please try again?
> > Oleg.

Weird. Well, I just resent it.

Thanks,
Gil
Oleg Chernavin 10/03/2003 10:11 am
I just received it. Thank you.

Oleg.