Internal Browser Question

Author Message
Steve 03/29/2006 07:02 am
I am trying to get the internal browser to display a serieis of pages beginning with:

http://mlsrealestatesearch.com/SearchPages/Index_Tri.cfm?clientid=47

then

http://mlsrealestatesearch.com/SearchPages/All_Cities.cfm?clientid=47

that results in several pages being displayed after hitting Search button with all default values in form (nothing is explicitly entered).

http://www.mlsb.com/mls/advresults.cfm?ClientID=904&StartRow=11&setbd=6&PropType=Any&MinSqFt=0&ZIPLIST=&MinBaths=1&MinBed=1&MinPrice=0&MaxPrice=300&rf=2&Pool=Any&MinGarages=Any&MinAge=0&MaxAge=500&MinAcreage=0&MaxAcreage=10000&Stories=Any&Horse=Any&arealist=Any&subdivlist=Any&ssc=2

I even tried just entering the above URL string and seeing what internal browser would return but the session just hangs with the "opening page ..." message in lower left hand corner of screen.

It works in normal IE session -- I can even copy them to a new browser window and they work. But in OE Pro internal browser I get an error saying "account id is in error". I think it must have something to do with cookies. I even went thru the sequence of entering originating URL (www.harris-for-homes.com) in internal browser and then accessing each link thinking that the cookie or other identifying data string was set earlier in the query but nothing changes -- error still occurs.

Thanks,

Steve



Oleg Chernavin 03/29/2006 07:02 am
Steve,

I was able to do it this way:

I entered http://mlsrealestatesearch.com/SearchPages/Index_Tri.cfm?clientid=47 in the Internal browser, then clicked the "Cross County Search" link. On the search form page and pressed and hold down Ctrl + Alt keys and clicked the big Search button. Then I released the keys on keyboard.

Offline Explorer showed a new Project window with the search form information recorded. I set Level to 2 and clicked OK button. Then I started loading it and after the download completed, I got all pages on my hard disk easily browsed.

Please see if you can repeat these steps.

Best regards,
Oleg Chernavin
MetaProducts corp.
Steve 03/29/2006 07:02 am
Oleg -

I did as instructed -- but still get only 1 file downloaded and it is the following error:

"Account ID not specified correctly. Please contact your site administrator."

This is what the project looks like after navigating to cross county search form and holding down ctrl+alt keys while clikcing on the large Search icon:

http://www.mlsb.com/mls/advresults.cfm
POST=clientid=904&zip=196&setbd=6&ssc=1&MinPrice=0&PropType=Any&MaxPrice=10000&Stories=Any&MinBed=1&MinAge=0&MinBaths=1&MaxAge=500&MinAcreage=0&Horse=Any&MaxAcreage=10000&Pool=Any&MinSqFt=0&MinGarages=Any&x=87&y=18
IgnoreLogOutLinks
Referer=http://mlsrealestatesearch.com/SearchPages/All_Cities.cfm?clientid=47
SetCookie=ORGANIZER=6588

Level Limit was checked and set for 2.

No other options (like finlname or directory includes/excludes) have been used.

I am using OE Pro version 2.8.1241 SR 2.

Any ideas?

Thanks,

Steve

> Steve,
>
> I was able to do it this way:
>
> I entered http://mlsrealestatesearch.com/SearchPages/Index_Tri.cfm?clientid=47 in the Internal browser, then clicked the "Cross County Search" link. On the search form page and pressed and hold down Ctrl + Alt keys and clicked the big Search button. Then I released the keys on keyboard.
>
> Offline Explorer showed a new Project window with the search form information recorded. I set Level to 2 and clicked OK button. Then I started loading it and after the download completed, I got all pages on my hard disk easily browsed.
>
> Please see if you can repeat these steps.
>
> Best regards,
> Oleg Chernavin
> MetaProducts corp.
>
Oleg Chernavin 03/29/2006 07:02 am
Steve, I just tried to insert the lines from your latest post to Offline Explorer Pro on another computer and this worked well (I didn`t browse the original site). The only difference - I removed the SetCookie= line. Can you try to remove it as well, click OK button and retry downloading?

Oleg.
Steve 03/29/2006 07:02 am
Oleg -

Removing the Cookie line appears to have worked! Thanks!!

Now, can you explain for me what the Ctrl+Alt combination does while in the internal browser and also how the Cookie (and lack of) line works and affects the download -- as was the case in this instance?

How do I/we know to remove the Cookie line (or add another), etc.? Is it basically a trial and error process until a combination works?

Thanks again for the prompt and accurate responses!

Steve

> Steve, I just tried to insert the lines from your latest post to Offline Explorer Pro on another computer and this worked well (I didn`t browse the original site). The only difference - I removed the SetCookie= line. Can you try to remove it as well, click OK button and retry downloading?
>
> Oleg.
Oleg Chernavin 03/29/2006 07:02 am
Steve,

Ctrl+Alt simply tells Offline Explorer to add the next link you click as a Project. If it is a form submission, all form data will be also added to the Project. Thus, it is an easy way to remember logons, searches, etc. The Cookies line works fine in most cases. I simply noticed that when adding a Project on my computer, there was no cookies added, that`s why I made that suggestion.

Oleg.