Url Macro for incrementing {:1..10} fails with numbers starting with 25 and 40

Author Message
Oscar 03/29/2006 07:02 am
When using the incrementing function eg. {:1..1000} i get al files but those starting with 25 and 40 are downloaded as 5F25, 5F40...5F49, 5F250....5F259

lets say the file starts like : test_1.img until test_500.img then it downloads all but only files like test_25.img are renamed to test_5F25.img and test_40.img will be test_5F40.img, same by 250-259. Seems like a problem with numbers starting at 25 or 40.

?????
Oscar 03/29/2006 07:02 am
Find out that it has to be of the underline _ char. The hex-value of this one is also 5F. It interprets its value wrong i guess.


> When using the incrementing function eg. {:1..1000} i get al files but those starting with 25 and 40 are downloaded as 5F25, 5F40...5F49, 5F250....5F259
>
> lets say the file starts like : test_1.img until test_500.img then it downloads all but only files like test_25.img are renamed to test_5F25.img and test_40.img will be test_5F40.img, same by 250-259. Seems like a problem with numbers starting at 25 or 40.
>
> ?????
Oleg Chernavin 03/29/2006 07:02 am
I am sorry for this problem, but this was done to prevent conflicts with some filesystem problems. Actually, all these files are being loaded from the Web site with correct URLs. They only get renamed this way on the hard disk. Usually this doesn`t provide any problem, because Offline Explorer changes all offline links automatically. Also, when you update the site, it will check for updated files with the correct URLs.

Anyway, if this is a problem for you, please let me know with details. I may have some solution.

Thank you.

Best regards,
Oleg Chernavin
MetaProducts corp.
Kevin Collins 03/29/2006 07:02 am
Oleg,

I ran into this problem generating static files from a dynamic site. I have link translation disabled, so I need a way to avoid having pages 25 and 40 in each category renamed on the hard disk. What`s the workaround?

Thanks,
Kevin Collins

> I am sorry for this problem, but this was done to prevent conflicts with some filesystem problems. Actually, all these files are being loaded from the Web site with correct URLs. They only get renamed this way on the hard disk. Usually this doesn`t provide any problem, because Offline Explorer changes all offline links automatically. Also, when you update the site, it will check for updated files with the correct URLs.
>
> Anyway, if this is a problem for you, please let me know with details. I may have some solution.
>
> Thank you.
>
> Best regards,
> Oleg Chernavin
> MetaProducts corp.
Oleg Chernavin 03/29/2006 07:02 am
Well, there is no workaround for that right now. But why you are using No Links Translation?

Oleg.
Kevin Collins 03/29/2006 07:02 am
> But why you are using No Links Translation?

I want the URLs and links to stay the same because I`m using OE to create a static, "cached" version of a dynamic site, not for offline browsing. Creating the static files speeds up the site and frees up the database.
Luc 03/29/2006 07:02 am
I have the same problem and I`m looking for a solution. I only need pictures from some sites, so link translation is no help here. Renaming the pics later by hand makes some more work, any idea how to do this in a more easy way?

And why is this happening only for some sites?
Oleg Chernavin 03/29/2006 07:02 am
OK. Would it work for both of you, if I make OE to keep filenames as they are when No Translation is turned on?

Oleg.
Kevin Collins 03/29/2006 07:02 am
> OK. Would it work for both of you, if I make OE to keep filenames as they are when No Translation is turned on?
>
> Oleg.

Works for me!
Oleg Chernavin 03/29/2006 07:02 am
OK. Here is the updated oe.exe file version:

http://www.metaproducts.com/download/betas/oep1790.zip

Oleg.
Kevin Collins 03/29/2006 07:02 am
Wow that was fast!

Thank you!
Oleg Chernavin 03/29/2006 07:02 am
You are welcome! Does this work well for you?

Oleg.
Kevin Collins 03/29/2006 07:02 am
> Does this work well for you?

I`ll give it a run-through this afternoon and let you know how it works. Thanks again!
Luc 03/29/2006 07:02 am
> You are welcome! Does this work well for you?

For me it works. Thanks very much for this fast update.

There seems to be also no disadvantage, for me this prob show before mostly on sites used gallerys like Arles Image Page Creator and they are still offline browsable with No Translation selected.
Kevin Collins 03/29/2006 07:02 am
Oleg,

Can I simply rename my existing OE.exe (version 3.3.0.1758) and drop this new one in its place? Or do I need to uninstall / reinstall?

Thanks,
Keivn
Oleg Chernavin 03/29/2006 07:02 am
Sure, just replace the oe.exe file with the new one. The upgrade is easy!

Oleg.
Kevin Collins 03/29/2006 07:02 am
Oleg,

The upgrade worked like a charm! Thanks for a fantastic product and amazing support!

Kevin Collins
Oleg Chernavin 03/29/2006 07:02 am
Great!

Oleg.