Just wondering...

Author Message
Frederick 03/29/2006 07:02 am
Hi Oleg,

Just wondering whether OEP can capture server side image map links or not? I need to capture some sites for offline use but the page only contains a few images (of printed passage) and all links (one link per word) are server side image maps. Can you help?

Thanks

Frederick
03/29/2006 07:02 am
Dear Frederick,

Frankly, Offline Explorer doesn`t yet explore server-side maps automatically. However it is not hard to do it using URL Macros. Just let me know the URL of a page with the server-side map and I will show you how to load links from it.

Best regards,
Oleg Chernavin
MetaProducts corp.
Frederick 03/29/2006 07:02 am
Thanks for your reply.

If possible, please show me how to grab all valid links from http://www-users.cs.york.ac.uk/~fisher/cgi-bin/gnt?id=0101

Thanks

Frederick

> Dear Frederick,
>
> Frankly, Offline Explorer doesn`t yet explore server-side maps automatically. However it is not hard to do it using URL Macros. Just let me know the URL of a page with the server-side map and I will show you how to load links from it.
>
> Best regards,
> Oleg Chernavin
> MetaProducts corp.
GregF 03/29/2006 07:02 am
FYI I have found that by going to a webpage that the image map links to, and starting the scan from there, OE Pro seems to get all the links that way.

> Thanks for your reply.
>
> If possible, please show me how to grab all valid links from http://www-users.cs.york.ac.uk/~fisher/cgi-bin/gnt?id=0101
>
> Thanks
>
> Frederick
>
> > Dear Frederick,
> >
> > Frankly, Offline Explorer doesn`t yet explore server-side maps automatically. However it is not hard to do it using URL Macros. Just let me know the URL of a page with the server-side map and I will show you how to load links from it.
> >
> > Best regards,
> > Oleg Chernavin
> > MetaProducts corp.
Oleg Chernavin 03/29/2006 07:02 am
Thank you for the tip. However I want to add a normal support for server-side Image maps. After I suggested to use URL Macros, I realized that links on the site will not work and the only way to browse the site would be to use Project Map tab. So, I am now working to provide a better way for this.

Oleg.
GregF 03/29/2006 07:02 am
Another program I used had a checkbox for "ping server-side maps" or something like that, if that helps.

> Thank you for the tip. However I want to add a normal support for server-side Image maps. After I suggested to use URL Macros, I realized that links on the site will not work and the only way to browse the site would be to use Project Map tab. So, I am now working to provide a better way for this.
>
> Oleg.
Oleg Chernavin 03/29/2006 07:02 am
Yes, I know it. I will try to do something like that.

Oleg.
Frederick 03/29/2006 07:02 am
> FYI I have found that by going to a webpage that the image map links to, and starting the scan from there, OE Pro seems to get all the links that way.
>

Thanks for your suggestion.

But this does not work with my case, which links back to cgi-bin on server side. The returned page is of the same page, with different parameters attached to the end of URL. Take a look at http://www-users.cs.york.ac.uk/~fisher/cgi-bin/gnt?id=0101 and you will know why.

Oleg, I`m longing for your solution.


Thanks anyway.

Frederick
Oleg Chernavin 03/29/2006 07:02 am
It looks like I finally finished adding server-side Image maps support to Offline Explorer Pro. Please download the following file and replace the old oe.exe file with the new one:

http://www.metaproducts.com/download/betas/oep1246.zip

By default, exploring such maps is turned on. Please test the new version and let me know how it works. Thank you!

Oleg.