BBC - RTSP Parameters are not supported

Author Message
Fred F. 03/29/2006 07:01 am
Hello M.P.

I am trying to download from the BBC Website but am having no luck.

Here is the Log of the transaction, can you offer any advice?

Kind regards

Fred F.

RTSP0: Connecting to Proxy server...
RTSP0: Host rmv8.bbc.net.uk connected. Waiting for rtsp://rmv8.bbc.net.uk/radio2/desmond.ra.
RTSP0: GET http://rmv8.bbc.net.uk:554/SmpDsBhgRl632609c2-b457-11d6-8c75-00c0df030e23?1="1" HTTP/1.0
RTSP0: User-Agent: RealPlayer G2
RTSP0: Expires: Mon, 18 May 1974 00:00:00 GMT
RTSP0: Pragma: no-cache
RTSP0: Accept: */*
RTSP0: Transferring data from rtsp://rmv8.bbc.net.uk/radio2/desmond.ra.
RTSP0: RTSP/1.0 400 Bad Request
RTSP0: CSeq: 1
RTSP0: Date: Mon Mar 3 22:51:46 2003
RTSP0: RTSP Parameters are not supported.
Oleg Chernavin 03/29/2006 07:01 am
Dear Fred,

Were you able to load any other RTSP URL via your proxy server? If yes, can you tell me, if your proxy server is a public or not? I would like to test the URL myself via the proxy.

Downloading the rtsp://rmv8.bbc.net.uk/radio2/desmond.ra URL directly from the BBC site goes well with Offline Explorer Pro.

Best regards,
Oleg Chernavin
MetaProducts corp.
Fred F. 03/29/2006 07:01 am
Hello Oleg

Many thanks for your prompt reply.

So far I have not been able to download any RTSP files at all using any of the many programmes I have tried, including `Pro`.

I don`t think I have a proxy server, but perhaps you could enlighten me more in this respect in case I do have but don`t know it.

Are you saying that you managed to download the programme OK?

Kind regards

Fred F.
Oleg Chernavin 03/29/2006 07:01 am
Fred,

From the log above I saw that you are using a proxy server - "Connecting to Proxy server..." line. Please try to go to the Options dialog | Proxy | RTSP and select "No proxy" there. Then click OK button and try to download the BBC URL again.

It really worked on my connection and I got a file correctly.

Oleg.
Fred F. 03/29/2006 07:01 am
Hello Oleg

Sorry It looks as though I had set the option while I was trying things out.

I have now changed it and am sorry to say I am still unable to download.

Here is the latetst Log.

Any further advice?

Kind regards

Fred F.

RTSP0: Looking up host rmv8.bbc.net.uk...
RTSP0: Connecting to host rmv8.bbc.net.uk...
RTSP0: Host rmv8.bbc.net.uk connected. Waiting for rtsp://rmv8.bbc.net.uk/radio2/desmond.ra.
RTSP0: OPTIONS rtsp://rmv8.bbc.net.uk:554 RTSP/1.0
RTSP0: CSeq: 1
RTSP0: User-Agent: RealMedia Player Version 6.0.8.1649 (win32)
RTSP0: ClientChallenge: c0157933aef7a60918e1de5feddf9996
RTSP0: PlayerStarttime: [05/08/2002:14:08:53 03:00]
RTSP0: CompanyID: bIiTbEtEphx7i07QEFdl+A==
RTSP0: GUID: 00000000-0000-0000-0000-000000000000
RTSP0: RegionData:
RTSP0: ClientID: WinNT_5.0_6.0.10.505_RealPlayer_RN9GPD_en_686
RTSP0: Pragma: initiate-session
RTSP0: Transferring data from rtsp://rmv8.bbc.net.uk/radio2/desmond.ra.
RTSP0: RTSP/1.0 305 Use Proxy
RTSP0: CSeq: 1
RTSP0: Location: rtsp://62.255.0.7:9231/
RTSP0: RTSP Parameters are not supported.
Oleg Chernavin 03/29/2006 07:01 am
You need to try the following:

Go to the Options | Proxy | RTSP - select "RTSP Proxy" and place 62.255.0.7 to the Address and 9231 to the Port. Click OK. Does this help?

Oleg.
Fred F. 03/29/2006 07:01 am
Hello Oleg

Once again many thanks for your guidance.

Yes!!!!

This has worked, and I ended up with a file with an extension .ra@

I re-named it to .ra and it is now playing

You really are some kiddo - I sould have come to you first - it would have saved me weeks of searching forums and trying things out.

I will no doubt be back with plenty more questions, but at least I now know that you prog. will do the job.

Subscription will come through under my real name of course.

Kind regards and may thanks

Fred F.

Oleg Chernavin 03/29/2006 07:01 am
> Once again many thanks for your guidance.

You are welcome!

> This has worked, and I ended up with a file with an extension .ra@

This is strange. The URL you were using didn`t contain @ or ? at the end, according to the log, did it?

> I will no doubt be back with plenty more questions, but at least I now know that you prog. will do the job.

Yes, feel free to ask me.

> Subscription will come through under my real name of course.

Thank you!

Oleg.
Fred F. 03/29/2006 07:01 am
Hello Oleg

As far as I know it didn`t have an @ but it might have had a ? when I used it as this is how they come up when I `grab` the address from the site. e.g.

rtsp://rmv8.bbc.net.uk/radio2/desmond.ra?start="27"

I have noticed the same thing on a couple of other downloads.

If it happens again I will let you have a copy of the log - or at least the relevant bits!

Kind regards

Fred F.


>
> > This has worked, and I ended up with a file with an extension .ra@
>
> This is strange. The URL you were using didn`t contain @ or ? at the end, according to the log, did it?
Oleg Chernavin 03/29/2006 07:01 am
> As far as I know it didn`t have an @ but it might have had a ? when I used it as this is how they come up when I `grab` the address from the site. e.g.
>
> rtsp://rmv8.bbc.net.uk/radio2/desmond.ra?start="27"
>
> I have noticed the same thing on a couple of other downloads.

Oh, yes - it works this way. As you know, ? symbol cannot be used in filenames. So I have to replaced it with @.

Oleg.
Fred F. 03/29/2006 07:01 am
Hello Oleg

Do you think it might be an idea to write the detail which comes after `.ra` e.g. time stamp etc so that it comes after the file name, but before the `.`

This would mean that the files would be ready for use without having to re-name them.

Kind regards

Fred F



> > rtsp://rmv8.bbc.net.uk/radio2/desmond.ra?start="27"

> Oh, yes - it works this way. As you know, ? symbol cannot be used in filenames. So I have to replaced it with @.
>
> Oleg.
Oleg Chernavin 03/29/2006 07:01 am
Actually, when you are browsing inside Offline Explorer, it should automatically tell the browser actual file MIME type, so this should not be a big problem. Anyway, such symbols after .rm or .ra might be essentual. Different files could be named the same way and only symbols after the extension will help to save them all independently.

Oleg.