Files downloaded from RSTP protocol are corrupt

Author Message
Bruno 03/29/2006 07:01 am
I tried to play them in RealPlayer 8 but the player asks for an update and when it finishes the player asks again for the same update! I thought I could solve that problem if I install RealOne but now the player says it didn`t find a software to play the files. This only happened with RealVideo 9, RealVideo 8 plays normally. I know that`s a problem with Offline Explorer because when I try to play the video online everything goes fine. Is there a way to solve this problem? If I download the files again will I have the same problem?

Thank you!
Oleg Chernavin 03/29/2006 07:01 am
Dear Bruno,

Can you please let me know a link to such RealVideo file? I will test it to see what is wrong and improve the downloading code.

If you don`t want to share the link in the forum, please send it to us directly: support@metaproducts.com

Thank you.

Best regards,
Oleg Chernavin
MetaProducts corp.
Bruno 03/29/2006 07:01 am
Ok, here they are:
http://www.eonline.com/shared/Eonline/Features/Awards/Golden2003/nicole_kidman_globes_03_eol.ram
http://www.eonline.com/shared/Eonline/Multimedia/ENewsDaily/enews.121702.ram
Oleg Chernavin 03/29/2006 07:01 am
Thank you. The problem is not in the RTSP downloading code, but rather in .ram files processing when Internal server changes RAM URL on-the-fly. I just fixed the problem. For a quick workaround, I would suggest you to access the actual .rm file using the Project Map.

Oleg.
Bruno 03/29/2006 07:01 am
Ok, I`ll try that!

Thanks a lot once again!
Bruno 03/29/2006 07:01 am
Hello again!
I just need to know if OE Pro 2.7 SR2 has this problem fixed.
Oleg Chernavin 03/29/2006 07:01 am
Yes, it has it fixed.

Oleg.