Start-End-Feature in RTSP protocols / Timestamps ?

Author Message
Spider9999 03/29/2006 07:01 am
Q: Though updated to OE Pro 2.7, start-end-feature using rtsp protocols isn`t working for me :-(.
What`s going wrong?

i.e. rtsp://xxx.yyy.net:554/zzz.rm?start=00:30:00.00&end=00:50:00.00

but unfortunately new DL starts from the beginning 00:00:00.0 again ...

Q: Heard about timestamps in rtsp-protocols :-o, so what ? Can timestamps change during DL of longer .rm-files and cause broken DL`s ???

Thx for your patience (for I`m a novice in DLing streaming media ;-) and greetings from Berlin,

Spider9999
Oleg Chernavin 03/29/2006 07:01 am
I am glad that you are asking. Such requests help us to improve our software.

1. Can you please send me the link you are downloading? You can use support@metaproducts.com to send information that you don`t want to share widely.

2. Each stream includes time stamps for each packet server sends. These timestamps should not be changed during downloads and they do not cause broken .rm files.

Oleg.
Spider9999 03/29/2006 07:01 am
email sent, maybe it helps to fix some problems.

Best regards from Berlin,
Spider9999


> I am glad that you are asking. Such requests help us to improve our software.
>
> 1. Can you please send me the link you are downloading? You can use support@metaproducts.com to send information that you don`t want to share widely.
>
> 2. Each stream includes time stamps for each packet server sends. These timestamps should not be changed during downloads and they do not cause broken .rm files.
>
> Oleg.
Oleg Chernavin 03/29/2006 07:01 am
Thank you!

Oleg.
Spider9999 03/29/2006 07:01 am
Hi Oleg,

here`s another (but easier to handle than the one I`ve e-mailed to you, cause no timestamps or pw in here) example for non-working start/end-feature in rtsp-streaming-D/L (OE Pro 2.7):

Pls try:
rtsp://66.28.50.199:554/MatthewRush.rm
rtsp://66.28.50.199:554/MatthewRush.rm?start=00:05:00.0&end=00:06:00.0
rtsp://66.28.50.199:554/MatthewRush.rm?start=00:05:00.00&end=00:06:00.00

( !!! For all minors oin here: Caution! Smart, but jerking guy .. ;-) !!! )

All href`s above start downloading (good news: all until the end if wanted & finalizing is possible in these cases), but when playing with RP8+ unfortunately they all do start from position 0:00:00.0 :-(
Maybe indexing problem, esp. when finalizing ? I don`t know ...
(BTW: other rtsp-streaming clips partly can`t be finalized ...)

Clip info on MatthewRush.rm (delivered by RealMedia Editor 8.5 after COMPLETE D/L):
Total: size 20.890 MB, length: 13:00.050
160x120, Single Rate
Stream 0: Audio: bitrate=32115, preroll=5682, sampling rate=22050, codec=`32 Kbps Voice`
Stream 1: Video: bitrate=187959, preroll=9480, frame rate=15, codec=`Real Video G2`

Perhaps this helps for further improvement of your already great product !

Best regards from Berlin,
Spider9999

spider9999@web.de





> Thank you!
>
> Oleg.
Oleg Chernavin 03/29/2006 07:01 am
I just played with some Real Media files settings there, but the player still shows 00:00:00 as the clip start time no matter how I try to change the file contents. More over, the file itself contains original time stamps for every frame (that start not from 0). This looks quite strange to me.

Do streams editing software show correct frame times or not?

Oleg.
Spider9999 03/29/2006 07:01 am
Hi Oleg,

made some screenshots according to your questions (screenshots.zip appended to the sent email):

1: When playing the whole D/L (OE Pro 2.7) file MatthewRush.rm in RealMedia Editor 8.5 I do get correct frame times (1-000.gif up to 1-005.gif) and quick jump in the file is possible, so indexing seems to be correct ?!

2: Screenshots while playing the file streaming (ISDN 2-CH 128kbs) with RealPlayer Plus 8 and
shown statistics (2-000.gif up to 2-006.gif).

3: Screenshots while streaming with different start parameters (3-001.gif up to 3-003.gif), works correctly.

For I`m quite a novice, I don`t understand what you mean with original time stamps for every frame - uugh ;-). I`ve done my best, maybe it helps ...

Greetings from Berlin,
Spider9999

> I just played with some Real Media files settings there, but the player still shows 00:00:00 as the clip start time no matter how I try to change the file contents. More over, the file itself contains original time stamps for every frame (that start not from 0). This looks quite strange to me.
>
> Do streams editing software show correct frame times or not?
>
> Oleg.
Oleg Chernavin 03/29/2006 07:01 am
OK. Thank you. I just got your E-mail. I will work on it now.

Oleg.