oep1049 causes access violations

Author Message
Tony Edwards 03/29/2006 07:01 am
I downloaded oep1049.zip and restored an old saved project, the new url filter worked well - thanks. But when I turned the speed up I got access violations and the channels stopped one at a time until I had no download. The messages were - "Access Violation at address 0048FD19 in module OE.exe read of address 015830000"

Also, every couple of minutes the cpu utilisation goes to 100% for 15 seconds or so. Its not a power problem as I run a 2G cpu with 1G of ram and lots of fast disk.
Oleg Chernavin 03/29/2006 07:01 am
Dear Tony Edwards,

Can you please try another update, that I just uploaded to the site:

http://www.metaproducts.com/download/betas/oep1054.zip

Please unzip it and place updated file to the directory where Offline Explorer Pro is installed.

Let me know if the problem persists.

Regarding CPU usage - most probably it is Auto Save feature. It is set to 5 minutes by default. You can turn it off in the Options dialog | Advanced section.

Thank you.

Best regards,
Oleg Chernavin
MetaProducts corp.
Tony Edwards 03/29/2006 07:01 am
Thanks Oleg

I have now had a chance to test the patch - thanks.
With some old restore files I still got access violations, but with files created with this patch I don`t.
I can live with that :-)) I have deleted my old restore files, its just me being lazy.

I still get the intermittent 100% utilisation though.
I have turned off the save function but it seems to make no difference.
I have also tried it with and without a list of filter url s, again it seems to make no difference.

I seem to have lost the ability to edit the queue.
If I abort a single or group of url s they just reappear further up the queue, very strange.
Is it me :-( or is there a problem.
Is it possible to edit the saved queue in a text editor and then reload it somehow ?

thanks
Oleg Chernavin 03/29/2006 07:01 am
The queue problem was fixed just recently. I also worked on a better queue performance and as I heard from another user, it made things somewhat better. Can I ask you to download another update?

http://www.metaproducts.com/download/betas/oep1060.zip

Please keep me informed on how it works. Thank you!

Oleg.
Tony Edwards 03/29/2006 07:01 am
I downloaded 1060 but still have the queue edit problem

If I select a group of url s and either delete or abort them, the window refreshes but the url s are still there. If I do it one url at a time, they go away, but they then reappear. Very strange.
Oleg Chernavin 03/29/2006 07:01 am
So, you make Abort, but they appear again in the same place or at the end?

Oleg.
Tony Edwards 03/29/2006 07:01 am
> So, you make Abort, but they appear again in the same place or at the end?
>
> Oleg.

Single url s reappear in the same place, but blocks of url s seem to reappear a little but higher in the queue.

tony
Oleg Chernavin 03/29/2006 07:01 am
Can you try a simple workaround? When you need to abort some files, press F9 key once. This will put Offline Explorer in a "Suspend" mode. Please wait until current downloads finish and then try to abort the desired Queue URLs again - will this help?

Oleg.
Tony Edwards 03/29/2006 07:01 am
Oleg

I tried this already, but have just repeated the experiment.
The url s dissapear from the list, but if you scroll down the list and then back up again, they are back where they were. They seem to be deleted from the window but not from the actual queue.