SharePoint 2010 Nested Folders won't open

Author Message
Rob 01/06/2015 08:29 am
Hi,

I am using Offline Explorer Enterprise v6.9.4156 SR1 to create an archive of a SharePoint 2010 site. I've got it setup to download all files at 15 levels as a full offline conversion. My problem is when I have a document library that has folders within. When I click on a folder, I get the "Document not found" error screen. When I click "Download the missing link now...", nothing happens. Also, the link on this error screen is

http://127.0.0.1:800/Default/SiteName.com/Accounts%20Receivable/Forms/AllItems.aspx@RootFolder=..%2F701681-A%203rd%20Floor&FolderCTID=0x012000CD3C10EA5C5ED448B33C9A7169FF726E&View=%7B88DE81C4-89EB-4DAD-BB5B-8E84C53682CD%7D

It looks like an error is being created in the link above after the @RootFolder= part. The "..%20" before the beginning of the folder name "701681-A 3rd Floor" should not be there.

I have discovered that if from the document library, if I delete "Forms/AllItems.aspx" from the URL and replace it with the exact folder name (spaces and all) that the folder will open and I will have functional access to all of my files. This is not an acceptable method of accessing files in this archive, and not why I paid for the Enterprise version.

Any help would be greatly appreciated! Even if I have to do modification of code pages, just so that I can get this archive created and fully functional.
Oleg Chernavin 01/07/2015 03:59 pm
I sent a reply by E-mail to you. Please see if you received it.

Thank you!

Best regards,
Oleg Chernavin
MP Staff
Rob 01/12/2015 10:06 am
Just to update this post and help anyone else who may encounter this issue, Oleg was able to help me get it corrected via the information below.

There is a complex script that calculates the URL and fails to work properly offline.

There is an easy way to turn it off. Use the Project Properties dialog - Parsing section - URL Substitutes button. Add two rules:

URL:
*
Replace:
onclick="return HandleFolder(
With:
on1click="return HandleFolder(
Apply to:
HTML Text

URL:
*
Replace:
onclick="
 return HandleFolder(
With:
on1click="
 return HandleFolder(
Apply to:
HTML Text
Make sure you change the Apply To field to HTML Text for both rules.


Thanks a lot, Oleg!
Oleg Chernavin 01/13/2015 05:17 pm
There will be no need to use these rules starting from the next version - 6.9 SR2. The parsing code will automatically disable such scripts with no special settings required.

Oleg.