internal browser works but autosave does not?

Author Message
Jonathan 06/08/2013 07:30 am
Hi,

I am currently trying the software and I find it quite useful in downloading certain type of webpages. Though I have encountered something weird and would like to ask for some clarifications.

It seems that sometimes autosave doesn't work on certain webpages despite that those pages can be opened with the internal/external browsers (in online mode)

The scenario is like this: while the webpage can be opened normally with the browser, when I use autosave, certain components (I think they are probably flash or activeX stuff) don't seem to work and the webpage can't show/be downloaded.

Here is one example: for some flash pages (they are e-learning modules made by I think articulate softwares "http://www.articulate.com/") most slides can be loaded/downloaded easily using autosave but some just can't no matter what setting I used. Sometimes it is the whole flash presentation, sometimes it is a certain slide within a presentation whose other slides can be downloaded.

Is this a known limitation of the software or am I setting something incorrectly?

Many thanks.
Jonathan
Jonathan 06/08/2013 07:42 am
Oh, I forgot to mention in the post that those are https webpages.
Oleg Chernavin 06/08/2013 08:30 am
I am afraid, some slides are impossible to download this way. Some scripts are very hard to make working offline. Each new version improves on that but I can't guarantee 100% compatibility.

There is no limitation at all. We plan to release a new version next week. Perhaps, it will be better with the sites you download.

Best regards,
Oleg Chernavin
MP Staff
Jonathan 06/08/2013 08:57 am
Thanks Oleg and I appreciate your quick reply. Maybe I will wait for the new release to see if it works then.
Oleg Chernavin 06/08/2013 09:53 am
I uploaded the current version of OE.exe file for you:

http://www.metaproducts.com/download/betas/OEE3961.zip

You may replace the older installed file with it and try.

Oleg.
Jonathan 06/09/2013 03:08 am
Thanks Oleg! I can confirm that this release works on some type of sites that I couldn't download before (not all of them unfortunately). Very great work!
Oleg Chernavin 06/10/2013 05:19 am
Thank you! Very good!

Oleg.
Jonathan 06/11/2013 01:49 am
Hi Oleg,

I have just encountered another problem. When I tried to download a flash presentation (with autosave), the project seemed to stop when it reached a component called something like "https://website.com/series/part1/player/playershell.swf?rqPresentationID=47J52mFqgJUOoru&rqStartSlide=1&link=https://website.com/series/part1/" (which appeared in the project properties as https://website.com/series/part1/player/playershell.swf?rqPresentationID=47J52mFqgJUOoru&rqStartSlide=1&link=http:/127.0.0.1:800/e-lecture/https?website.com/series/part1/) but the download worked fine for the presentations whose playershell.swf wasn't followed by the stuff behind. Is there any way that I can overcome this?

Thank.

Jonathan
Jonathan 06/13/2013 02:42 pm
Hi Oleg,

making this post just in case you miss the previous one. Do you have any idea how the problem could be fixed?

Thanks.
Oleg Chernavin 06/13/2013 02:56 pm
Sorry for the late answer! I can't tell from looking at the URLs. I need to reproduce it myself to see if anything could be improved.

Can you give me the real URL of the page and explain what links should be downloaded?

Oleg.