HELP ! - How to not use cookies? SetCookie= doen't work

Author Message
Dude 11/10/2012 04:38 pm
http://www.example.com/view.aspx?id={:46747979..46747999}
SetCookie=

I am trying to retrieve a website and after the first 10 default channels get 10 pages without sending Cookies to web-server, each channel gets a random generated session ASP.NET cookie in reply to a page request from web-server, then all additional pages OE tries to get your program send a set of cookies from one of the pages it just retrieved.

Q: How to stop OE from using any cookies or at least ASP.NET_SessionId= cookie when requesting pages beyond the maximum number of the channels that it opens initially?

--------------
On first 10:
HTTP Request Header:

GET /view.aspx?id=46747979 HTTP/1.1
Accept: */*
User-Agent: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 5.2; WOW64; Trident/4.0; Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1) ; .NET CLR 2.0.50727; .NET CLR 3.0.4506.2152; .NET CLR 3.5.30729; InfoPath.2; .NET4.0C; .NET4.0E)
Accept-Encoding: gzip
Host: www.example.com
Cookie: ft=Saturday, November 19, 2012 12:02:32 PM; my_ipcountry=1


HTTP Response Header:

HTTP/1.1 200 OK
Cache-Control: private
Content-Type: text/html; charset=utf-8
Content-Encoding: gzip
Vary: Accept-Encoding
Server: Microsoft-IIS/8.0
Set-Cookie: ASP.NET_SessionId=150111td3hytpgixuc150111; path=/; HttpOnly
X-AspNet-Version: 4.0.30319
X-Powered-By: ASP.NET
Date: Sat, 19 Nov 2012 21:15:10 GMT
Set-Cookie: abc_123;max-age=300;path=/
Transfer-Encoding: chunked

-----------

On beyond first 10 requests:
HTTP Request Header:

GET /view.aspx?id=46747991 HTTP/1.1
Accept: */*
User-Agent: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 5.2; WOW64; Trident/4.0; Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1) ; .NET CLR 2.0.50727; .NET CLR 3.0.4506.2152; .NET CLR 3.5.30729; InfoPath.2; .NET4.0C; .NET4.0E)
Accept-Encoding: gzip
Host: www.example.com
Cookie: ft=Saturday, November 19, 2012 12:02:32 PM; my_ipcountry=1; ASP.NET_SessionId=150111td3hytpgixuc150111; abc_123


HTTP Response Header:

HTTP/1.1 200 OK
Cache-Control: private
Content-Type: text/html; charset=utf-8
Content-Encoding: gzip
Vary: Accept-Encoding
Server: Microsoft-IIS/8.0
X-AspNet-Version: 4.0.30319
X-Powered-By: ASP.NET
Date: Sat, 19 Nov 2012 21:15:14 GMT
Transfer-Encoding: chunked

Oleg Chernavin 11/11/2012 10:47 am
You need to disable cookies at all - use the Internet tab on the Ribbon - uncheck the Use MS IE Cookies box.

Best regards,
Oleg Chernavin
MP Staff
Dude 11/11/2012 06:27 pm
That is the first thing I did and every possible variation of every thing I can find after that and it still passes cookies in subsequent requests.

I tried generating page links, pasting page links from clipboard, putting them in the file to be followed and every possible combination of every variable and it still passes cookies.



Stream 1.2 File
ObjectsCount=2
[Object]
OEVersion=Enterprise 6.4.0.3860
Type=1
Text=Default
Dir=
Expanded=True
Count=1
[Object]
Type=0
IID=7013
Caption=http://example.com/index.htm
URL=http://example.com/index.htm
Lev=1
Weekday=257
FMGroup=1
LTMethod=2
FTText.Exts=htmlhtmaspaspxjspstmstmlidcshtmlhtxtxttextxspxmlrxmlcfmwmlphpphp3
FTImages.Exts=gifjpgjpegtiftiffxbmfifbmppngipxjp2j2cj2kwbmplwfwebpico
FTVideo.Exts=mpgavianimpegmovflvfliflcvivrmramrvasfasxwmvm1vm2vvobsmilmp4m4vogv
FTAudio.Exts=wavriffmp3midmp2m3uravocwmaapeoggm4aaif
FTArchive.Exts=7zziparcgzzarjlhalayleirarcabtarpakacejarpdftgzexeiso
FTUDef.Exts=jsaxdcssssivbsdtdxslswfclassent
FTText.B=ooxooo
FTImages.B=xoxooo
FTVideo.B=xoxooo
FTAudio.B=xoxooo
FTArchive.B=xoxooo
FTUDef.B=xoxooo
FTOther.B=xoxooo
FTSizes=0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,3,3,3,0,3,0,0,0,0,0,0,0,0
NotIgnoreLogout=False
RSrvsBx=3
RProt=255
LastStart=143:253:162:48:24:33:228:64:
LastEnd=51:86:195:53:24:33:228:64:
PrjStart=146:227:117:183:23:33:228:64:
LastStarted=11/11/2012 6:08:32 PM
LastEnded=11/11/2012 6:09:27 PM
S200=16
SAbr=8
SPar=16
SSav=16
SLast=302
SSiz=445953
SMdf=15
SHTML=16
SSuccDowns=1
LFiles=16
LSize=172401
Stopped=True
Flags=1
ImgDim=0,0,0,0
PrevURL=http://example.com/index.htm
NoIgnoreErrors=True
SkipVideoBlocks=True
Oleg Chernavin 11/12/2012 12:13 am
I see. Can you please also uncheck the "Use alternative connection method" box?

Oleg.
Dude 11/12/2012 12:20 am
Where is that?
Oleg Chernavin 11/12/2012 12:22 am
The same Internet tab of the Ribbon.

Oleg.
Dude 11/12/2012 12:58 am
unchecked it doesn't retrieve any files.

Fond solution, I went to IE "Internet Options" -> "Privacy" -> "Settings" moved slider up to "block all cookies". I don't think that setting in OE "use IE cookies" gets disabled if you uncheck it.

Another question: Can OE use persistent connections like Keep-Alive ?
Oleg Chernavin 11/12/2012 01:50 am
Yes, good solution.

No, currently it can't, but I am working to add this in future. Including the new SPDY protocol.

Oleg.