Unstable in Windows 7

Author Message
Grios 03/03/2011 12:11 am
Recently I updated my system to Windows 7/64 and downloaded and installed OE. App is unstable after some minutes running: I receive an error message from Windows or simply OE is closed without any message. I tried also in a different computer and behaviour is similar. Opening the About submenu in Help menu apparently your software remains working an extended time over the "normal" behaviour. Is it related with the evaluation option?
OE version 5.9.3318 SR 3
Oleg Chernavin 03/03/2011 02:50 pm
Can you please try to uncheck the "Index downloaded files for faster search" box in the Project Properties dialog? Would it make a difference?

Also, what information do you see in the About dialog?

Thank you!

Best regards,
Oleg Chernavin
MP Staff
Grios 03/03/2011 06:32 pm
Thank you for your answer. The option Index downloaded files for faster search never was checked. I'm trying some additional options, perhaps issue is related with some kind of permissions. I was using the Windows setting for XP SP 3 compatibility (issue remained), now I'm working the app running as Administrator. If it works I'll advise you, I have now 24 days for runnin the tryout.
Oleg Chernavin 03/04/2011 05:06 am
Thank you! Please keep me informed.

Oleg.
Grios 03/07/2011 02:11 pm
I was looking at user/permissions level in directories related with OE and running it as Administrator but the misbeahviour continues, perhaps running OE as Administrator gives litle more time before the error message or fall without message of app.
Oleg Chernavin 03/10/2011 11:53 am
Can you please try to watch the memory usage of OE.exe during the download? You can open it with Ctrl+Shift+Esc and see the Processes tab. Mem Usage and VM Size columns are what is important.

Maybe it runs out of memory for some reason and crashes?

Oleg.

Grios 03/11/2011 09:54 am
Hello

I started OE, proccess CPU use goes between 1 and 6 percet, memory, after some minutes running 22.500-50.000 KB and current down (after 15 minutes running) was at 177,808 KB, but in resources monitor was 59% used Physical Memory. Program goes down in a non predictable way: sometimes after a couple minutes, sometimes after near to 30 minutes.

Loooking at general info about memory in system:
Physycal Memory: 4095
Cache: 1500-1650
Available 1300-1350
--------
Kernel Memory
Paginated (I'm not sure about traslation): 363
Non paginated: 91
--------
System
Identifiers: 26,500-27,000
Subproccesses: 950-980
Preccesses: 75

Grios 03/11/2011 09:54 am
Physical memory in computer is 4096, Pagefile.sys is 12228 MB (non fragmented, assigned by user).
Memory usage for OE runs from 10 MB to 77-80 MB at 10 minutes of starting, goes down and repeats cycle (in options is configured to Save changes every 10 minutes). Actual configuration is using 3072 bytes/second, using gzip encoding.
In typical work time:
Physical Memory:
Total: 4095
Cached: 1400-1500
Available: 1300-1400
-------------
Kernel memory
Paginated (I'm not sure for traslation): 340
Non paginated: 94
-------------
System
Identifiers: 31400
Subprocesses 1250
Processes 80
-------------
Resources monitor:
Processes: 62-66% physical memory used
Physical memory: 2600-2700 MB used
1300-1400 MB available
Oleg Chernavin 03/11/2011 09:56 am
Can you please use View - Select Columns menu to allow Virtual Memory Size display for the Processes tab? It is important to monitor VM Size for OE.exe process.

Oleg.
Grios 03/11/2011 12:52 pm
Hello
I don't see any option in columns named as virtual memory (my OS is in Spanish Language), but in memory related values in supossed traslations: Assignation size: 877,764 KB, Max work (task?) space: 104,236 KB, Memory (private space): 72,000, Work Space: 68,008, Paging block: 776 KB, Non paging block: 304 KB.
Oleg Chernavin 03/11/2011 03:45 pm
Yes, I think it is Assigned memory size column. If it is close to 2,000,000 KB, then Offline Explorer is really out of memory and it will crash. Please see how this value grows and if it gets close to that number.

Thank you!

Oleg.
Grios 03/12/2011 11:32 am
Hello
OE sometimes crash near to 1.100.000 but sometimes crash in really low values: 20,000 KB ar 177,000 KB. Not related with apps running: with system restarted, only OE and basic proccesses, or with any app open, there is no change in behaviour.
Oleg Chernavin 03/14/2011 01:53 pm
Please replace oe.exe file with the updated version:

http://www.metaproducts.com/download/betas/OEE3332.ZIP

If it crashes, please find the c:\download\oe.log file, zip it and send to us to support@metaproducts.com. Please post here when you send it. Thank you!

Oleg.
Grios 03/17/2011 03:52 pm
Hello
I'm using your beta: starting computer, without arunning any other app (excepted system loading apps), OE runs good and gets stopped (not crashed or blocked) a litle under 950,000 KB in virtual memory (perhpas it is a "normal" behaviour), but re-running OE shows same erratic behaviour: sometimes go out after a couple of minutes sometimes remains working up to one or two hours (crash messages from Windows are rare).
I used your beta and your distribution in windows XP using an old hard drive and rare times crash, works good for hours and if crashed re-running shows all ok, taking in mind Win XP (32) only uses RAM up to 3 GB. Pagefile is created using three times the physycal memory.
Oleg Chernavin 03/17/2011 04:03 pm
No crash log file created by this beta?

Oleg.
Grios 03/19/2011 03:12 pm
Hello. I'm unable to see any crash log. Do you reccomend some prodecure to obtain some kind of log for debugging your app. I'm 8 days before ending trial time.
Oleg Chernavin 03/19/2011 07:02 pm
Can you please contact me by E-mail at support@metaproducts.com ? We will discuss this better.

Oleg.
wbtstm 07/25/2011 04:01 am
hi,

i recently have the same problem and i can't solve it
i am using windows 7 ultimate 64 bit and 4 gb memory and 750 gb hdd and core i5 the first time i download a website a coupl of days i had no problem but now i can't do any download it crashes every 10 seconds of parsing the downloaded files
wbtstm 07/25/2011 06:30 pm
Sorry for that message, after reading the hole post again, I disabled parsing file and had no problem of crashing
Oleg Chernavin 07/25/2011 06:30 pm
Can you please post here, how exactly you did that? Thank you!

Oleg.
wbtstm 07/25/2011 08:32 pm
Hi,

Sorry, i posted the message without reviewing it.

I meant disable indexing files.

I think thant if i copy all the downloaded files of a project to an other pc and press ctrl+F5 with indexing checked it crashes systimatiquelly.

Oleg Chernavin 07/26/2011 04:15 pm
Oh, I see now. OK. I will try to reproduce this and fix. Thank you!

Oleg.
Oleg Chernavin 08/11/2011 03:13 pm
Can you please post Project settings that cause the crash? I can't reproduce it on several sites. Perhaps, this is site-specific.

Thank you!

Oleg.
wbtstm 08/11/2011 06:17 pm
No, it's due to temp files and maybe some file system problem.

because i reinstalled oee beta version and redo the same thing than before and oee didnot crash at all.

Thank you however and sorry again.
Oleg Chernavin 08/12/2011 03:52 am
OK. The temp files problem was fixed just recently.

Oleg.