Removing text from d/l webpage source

Author Message
sammie 02/21/2011 05:43 am
Hi Oleg,

Once I d/l a web page in OE, and view the webpage source using Dreamweaver CS4, I see the text

<!-- saved from url=(1234)http://www.mypage.com/index.html -->

just after the code

<!DOCTYPE html PUBLIC "-//W3C........

Now, if I remove this line (<!-- saved from url=....) and view the page in IE8, I get a warning

'To help protect your security, IE has restricted this webpage from running scripts or ActiveX......'

now if I put the line (<!-- saved from url=....) back in, IE8 does not give this warning.

Question is, how can I remove the line (<!-- saved from url=....) and IE not give me a warning?

I am assuming OE is adding the line (<!-- saved from url=....)

Regards,
sammie
Oleg Chernavin 02/21/2011 05:46 am
Yes, this line was added with the special purpose - to ensure better offline browsing compatibility when viewing pages from the disk.

I assume you made export of the site with the "Add original URL" box checked. This setting adds the line.

Regarding the warning - you should contact Microsoft support about the ActiveX contents warning and how to stop MS Internet Explorer from showing this message.

Best regards,
Oleg Chernavin
MP Staff
sammie 02/21/2011 07:00 am
I unchecked "Add original URL" box and have no problem now.

This was a strange problem because the 'original URL' text is a comment in the source and removing it should make no difference to the webpage loading.

Anyway thanks for that.
Oleg Chernavin 02/21/2011 07:37 am
This is how Internet Explorer is designed. They introduced this comment line format in IE 6.0 version, as I remember. Lots of security restrictions were added.

Oleg.