Downloaded file not being renamed correctly

Author Message
Vengab 05/23/2010 12:17 pm
Hi all,

I have an issue with Offline Explorer Enterprise not renaming downloaded files when there are 2 or more file urls in the queue.
If I give the project only 1 file to download, it renames the file to what it should be no problems.

Here is an example url...

http://website.com/cgi-bin/cs/mvsrch_front?KEY=%2BA5PMNGabiGbQ%2B/4DSzGPLjYCImkYkg8E0mnSg797VO4p0mxb%2B6HMnaClJYPeHWPEvbpAOYZt4OTjd3T%2BFD9kh2o2%2BCLv%2BDPDyYLCb7rbxjmE97jkVB8cgOMfQ24m4jsYrO0mZqsF9dkM7Jh6fcUN3iRypCykJiOxtxabYi1DJzMeeXSbY/rRZYkQr90n9w6NJDvpHBlJYJKt2v/Upwbtjw6SfCufYwEHpbcbp%2B/R9Dtm30WKwcLr0bCQvZsJ8fwNpxfRMxoEtFFMrfXu4zXIOs/PEedkUkksxDbrmXhT1YrrQA/8vzOQ8CpE6MB2hy7BkGoY1ztZlTmwDriu%2BvOWvmctDM7kIbBMCGxlc0teAnTprWzRAMu%2BWxQ5Gb3iEJtiAM4Re48UpNl7imYQU/bg%2B52/8ZIqYTb%2BwpU3VUs/yAF4733lTJmP2f8T7eifEoU7RWXYrdz7Sd2J8UQyhz4EhuObVgb6J2XCcLw%2BYZNJS2MayRgaoF8aNR5vWUV63U21%2Bosqq3dobM%3D

If that is the only url in the project it will save 2 files as follows...

1 small file about 124bytes named
mvsrch_front@KEY=+A5PMNGabiGbQ+_2F4DSzGPLjYCImkYkg8E0mnSg797VO4p0mxb+6HMnaClJYPeHWPEvbpAOYZt4OTjd3T+FD9kh2o2+CLv+DPDyY0EED7DA408

and
realfilename.jpg 3.06MB


If the project has 2 or more urls in the queue, the real file is saved as the big long KEY name with no extension.
I then have to go into a file renamer program and rename all the files. I have to give them a .jpg extension and I have no idea what the actual filename given by the website is so I just have to make up something.

The actual website is irrelevant as this happens with any site with a similar style/type of url.

I have tried every combination of settings in the options but nothing helps.


Thanks in advance for any assistance given

Regards
Vengab


Oleg Chernavin 05/23/2010 12:18 pm
Could you please describe me how I can reproduce this? Maybe some public site that shows such behavior?

Thank you!

Best regards,
Oleg Chernavin
MP Staff
Vengab 05/23/2010 12:46 pm
Thanks Oleg for your quick response and willingness to help.

However, I jumped the gun a bit.

I was using v4.7 and since noticed v5.8 is released so I tried it with the new version and it is working properly now.

Looks like it's time for an upgrade.

I also noticed with the long url in my 1st post it has really stretched the width of this thread and I don't seem to be allowed to edit it so either you can or delete the entire thread if you wish.

Regards
Vengab
Oleg Chernavin 05/23/2010 01:08 pm
Oh, great that it works well. Yes, you may upgrade - even now and all updates to 6.9 versions will be free. I am working on 6.0 version now.

Oleg.