Offline links and filenames of long URLs don't match.

Author Message
Oleg Chernavin 09/16/2009 08:36 am
Thank you! I fixed the error. You may replace the oe.exe file with the new version:

http://www.metaproducts.com/download/betas/OEE3106.ZIP

Best regards,
Oleg Chernavin
MP Staff
Cody 10/20/2010 10:24 am
Hi, I've made a post in this tread in the past saying that OEE cannot parse some long URLs correctly. It turned out that both oe.exe in OEE3106.ZIP and the newest version OEE are still not able to do that.
You can check it by trying to download the table of contents on this page:

http://www.sciencedirect.com/science/referenceworks/9780125126663

Just filter for files that contain "refwork".

Links for children of "Physics Subjects" are not working properly.

Thanks.

Cody.
Oleg Chernavin 10/20/2010 10:29 am
I downloaded this URL with Level=1 and the links with RefWork work well offline. I browsed in the Internal browser of Offline Explorer.

The links I clicked were General Information, Authors, Article Titles, Introductory Articles, Physics Subjects, Related Mathematics Subjects.

I used the latest 5.9 SR1 version.

Oleg.

Cody 10/21/2010 06:48 am
You've got to set Level=4. Level 1 links are short (<250 characters). The longer ones are inside "Physics Subjects" . There're only 100 files that will be downloaded. I've checked with the latest version of OEE.

After you finish downloading the project start it again (with "Do not download existing files" option). OEE will try to download the links that it messed up. They all will be error pages.

Cody
Oleg Chernavin 10/21/2010 07:21 am
Thank you! I fixed this error. Here is the updated oe.exe file:

http://www.metaproducts.com/download/betas/OEE3277.ZIP

Replace the old version of oe.exe file with this one.

Oleg.
Cody 10/22/2010 04:21 pm
Thanks, Oleg. But I wonder if the creation of %&Ovr folders is really necessary. Not only it's inconvenient, but it also makes the whole project unbrowsable because link translation does not take their existence into account. Maybe its just a bug?

Cody
Cody 10/22/2010 04:29 pm
Does OEE think that if a folder has more then 1000 files then it's overloaded? If that's true then that's a real disaster.
Oleg Chernavin 10/22/2010 05:28 pm
You can turn it off in the Options dialog - Files section.

1000 files is not a problem for a folder, but several thousand files with long filenames really overload a folder on FAT32 drives, so addition of other files becomes impossible.

NTFS cannot be overloaded this way, but 10,000-20,000 files in a folder cause it to be very slow when accessing it.

Oleg.