Website is not downloaded correctly (without images)

Author Message
Dennis 10/05/2008 12:58 pm
Can someone help me out with this website? http://www.tektvshop.com/nlnl/HomePage.aspx

I set the level limit to 3 but not even the homepage is displayed correctly when i browse it offline. I only see a white background with text urls.

Please help.

Regards, Dennis
Oleg Chernavin 10/06/2008 06:53 am
I would suggest you to select the Project that partially downloaded the site, click the AutoSave button on the Internal Browser toolbar and then click Browse. Offline Explorer Pro should download missing files.

Best regards,
Oleg Chernavin
MP Staff
Dennis 10/06/2008 09:18 am
I managed to download everything now except the following problems remain:

-videos are not downloaded
-some characters are not displayed correctly
Oleg Chernavin 10/06/2008 09:27 am
Where are the videos? Symbols - you may right-click the page in the browser and choose another encoding.

Oleg.
Dennis 10/07/2008 07:46 am
Here an example: http://www.tektvshop.com/Assets/Video/132_low_nl.wmv


Characters not displayed correctly example:

De Sewing Genie is dA© verbluffende nieuwe draagbare mininaaimachine.

De Sewing Genie is de verbluffende nieuwe draagbare mininaaimachine.

Oleg Chernavin 10/07/2008 01:42 pm
Video:

I understand, but where is the link to this video. I cannot understand the text on this page.

Text:

Right-click the page you are browsing and select another text encoding.

Oleg.
Dennis 10/08/2008 06:43 am
Hi Oleg,

The link is a javascript link: javascript:MM_openBrWindow(''/nlnl/Product/popUpVideo.aspx?

Which text encoding should i use? It does not change anything and i see only languages which don''t apply. Can''t this be fixed in another way? Especially since we have 20 computers trying to load this page a central solution is what i am looking for.

Regards, Dennis
Oleg Chernavin 10/08/2008 07:07 am
I used Level=1 to download it and even this low level setting downloaded two links from the home page:

http://www.tektvshop.com/nlnl/product/popUpVideo.aspx?productId=417
http://www.tektvshop.com/nlnl/product/popUpVideo.aspx?productId=132

And then Offline Explorer Pro started downloading videos:

http://www.tektvshop.com/Assets/Video/132_low_nl.wmv
http://www.tektvshop.com/Assets/Video/417_low_nl.wmv

It looks like this is correct. I tried to understand the encoding issue, but the home page doesn''t have the "De Sewing Genie is dA© verbluffende nieuwe draagbare mininaaimachine" sentence. I even searched for "draagbare" but no such word exist on this page.

Maybe this encoding issue is located on other pages?

Oleg.

Dennis 10/08/2008 07:55 am
You should search for the word naaimachine, here the link: http://www.tektvshop.com/nlnl/Product/ProductDetail.aspx?id=29


I noticed the video''s have been downloaded to /Assets/Video but when i click to play the video it opens a media player plugin but does not play the video.

I suppose it is not possible to use the search option in a downloaded website?
Oleg Chernavin 10/08/2008 09:01 am
It showed the correct encoding in my case. I have AutoDetect selected in MS IE and in this case it automatically uses Unicode (UTF-8). I also viewed it in FireFox 3.0 and it also used Unicode as well.

Regarding the video - it might be a problem with MS IE security and it may not allow the file to be played from the disk.

Search can be done using Offline Explorer''s Find Contents feature.

Oleg.
Dennis 10/08/2008 09:29 am
Hi Oleg,

It works with Unicode in both Firefox and IE. But when i close the browser and go to the site again i have to set the encoding again. Is it possible to set this to default somehow.

I can not play the video''s with Firefox either. Does it work for you?

Regards, Dennis
Oleg Chernavin 10/10/2008 09:25 am
> It works with Unicode in both Firefox and IE. But when i close the browser and go to the site again i have to set the encoding again. Is it possible to set this to default somehow.

Can you also check AutoDetect there as well? Would this keep this information?

> I can not play the video''''s with Firefox either. Does it work for you?

Yes, I just loaded the video on the page center and it worked in Opera and FireFox when browsing from inside Offline Explorer. MS IE may have problems playng the video directly from the disk, because of its security. Perhaps, it is better to use Export feature to generate EXE file for distribution.

Oleg.
Dennis 10/13/2008 07:45 am
Hi Oleg,

I found out that i have to turn off auto-select. The browser remembers the encoding in that case.

What is the export feature?

Regards, Dennis
Oleg Chernavin 10/13/2008 08:07 am
Wow! I thought it should act differently.

Export will copy the files of the Project to another folder. It is good because it may change filenames to fit CD filename formats, add standard extensions, so browsers have less issues browsing from the disk. It can also create other formats, like HTML Help, MHT, EXE viewer to have a single file with compressed contents.

FTP Upload is also there.

Oleg.