Export bug in EXE function

Author Message
Hass Chapman 11/29/2006 05:01 am
We are downloading the site www.helaprojektet.com for archiving and have noticed the following bug in the export function. After download we browse the site (before export) and choose Press-Pressmeddelanden. We come to the following url: http://127.0.0.1:800/Default/www.helaprojektet.com/net/HELA/Press/Pressmeddelanden which works fine.

However, once exported to EXE archive these links do not work! Even though if we write in /default.htm after them then the files have downloaded and exported.

Thanks in advance
/hass
Hass Chapman 11/29/2006 05:05 am
> We are downloading the site www.helaprojektet.com for archiving and have noticed the following bug in the export function. After download we browse the site (before export) and choose Press-Pressmeddelanden. We come to the following url: http://127.0.0.1:800/Default/www.helaprojektet.com/net/HELA/Press/Pressmeddelanden which works fine.
>
> However, once exported to EXE archive these links do not work! Even though if we write in /default.htm after them then the files have downloaded and exported.
>
> Thanks in advance
> /hass

I just remembered we reported this before and received a fix oebrowse.exe was the problem. We will try this fix on the new update of OE.
Hass Chapman 11/29/2006 05:06 am
No, this did not solve our problems.
Oleg Chernavin 11/29/2006 05:17 am
I used the latest 4.5 version of Offline Explorer Pro to download and export the project and it worked very well.

Best regards,
Oleg Chernavin
MP Staff
Hass Chapman 11/29/2006 06:40 am
> I used the latest 4.5 version of Offline Explorer Pro to download and export the project and it worked very well.
>
> Best regards,
> Oleg Chernavin
> MP Staff

Download works and the site is fully browsable. But when I export it then some links no longer work.

/Hass
Oleg Chernavin 11/29/2006 06:47 am
Is that .exe file big? If not (up to several MBs), can you please send it to me? The best way would be to upload to rapidshare.de server.

Oleg.
Hass Chapman 11/29/2006 07:06 am
> Is that .exe file big? If not (up to several MBs), can you please send it to me? The best way would be to upload to rapidshare.de server.
>
> Oleg.

I had to split the files into 2 parts. Rapidshare.de was full so I uploaded to rapidshare.com.

Our export can be downloaded at:

http://rapidshare.com/files/5293880/helaprojektet.part1.rar.html
http://rapidshare.com/files/5293446/helaprojektet.part2.rar.html

/hass
Oleg Chernavin 11/29/2006 07:11 am
Can you please make a smaller download with Level=1 and restrict files to make smaller exported .exe file and check if that link would work?

Oleg.
Hass Chapman 11/29/2006 07:18 am
> Can you please make a smaller download with Level=1 and restrict files to make smaller exported .exe file and check if that link would work?
>
> Oleg.

I sent a reply by email but in case it doesn't have a reply address:

Level=1 didn't work but just to test I set level=2 and then it worked fine for the links that were broken. Do you have an idea of how to fix this now?

/Hass
Oleg Chernavin 11/29/2006 10:30 am
Can you please try to download the following file and replace the previous one in the installation directory of Offline Explorer:

http://www.metaproducts.com/download/betas/OEBROWSE.EXE

Then make the export of the bigger download and see if this helps.

Oleg.
Hass Chapman 11/30/2006 01:57 am
This did not help. We still have the same problem.

http://127.0.0.1:5000/www.helaprojektet.com/net/HELA/Press/Pressmeddelanden

Still does not work after export to EXE even though if we manually type /default.htm after the url in the address bar it does then work so the file is exported.

/hass


> Can you please try to download the following file and replace the previous one in the installation directory of Offline Explorer:
>
> http://www.metaproducts.com/download/betas/OEBROWSE.EXE
>
> Then make the export of the bigger download and see if this helps.
>
> Oleg.
Oleg Chernavin 11/30/2006 02:52 pm
Please try another:

http://www.metaproducts.com/download/betas/OEBROWSE.EXE

I made a fix and it helped me.

Oleg.
Hass Chapman 12/01/2006 03:18 am
Hi,

Thanks. That is better. There is still some bugs though:
It works for Pressmeddelanden and Pressklipp from the start page but if you go to Pressklipp and then try Pressmeddelanden you still get an error. However, we can live with this I think.

/Hass

> Please try another:
>
> http://www.metaproducts.com/download/betas/OEBROWSE.EXE
>
> I made a fix and it helped me.
>
> Oleg.
Oleg Chernavin 12/01/2006 04:28 am
Sorry, this is because of the included script file that contained absolute links. We are aware of this issue, but so far we don't have a good solution.

Oleg.