Geting 400 and 401 errors when trying to download MP3 files

Author Message
Joshua Gregory 09/19/2006 12:17 pm
When I try to get an MP3, I ALWAYS get a 400 or 401 error. Below is my log of two separate attempts:

[9/19/2006 11:57:34 AM] HTTP0: Looking up host web.mac.com...
[9/19/2006 11:57:35 AM] HTTP0: Connecting to host web.mac.com...
[9/19/2006 11:57:35 AM] HTTP0: Host web.mac.com connected. Waiting for http://web.mac.com/atarwacki/iWeb/Simply%20Strategic%20Show/Podcast/Podcast_files/Simply%20Strategic%20Week%2028.mp3.
[9/19/2006 11:57:35 AM] HTTP0: GET /atarwacki/iWeb/Simply%20Strategic%20Show/Podcast/Podcast_files/Simply%20Strategic%20Week%2028.mp3 HTTP/1.0
[9/19/2006 11:57:35 AM] HTTP0: Accept: *.*, */*
[9/19/2006 11:57:35 AM] HTTP0: Accept-Language: en-us
[9/19/2006 11:57:35 AM] HTTP0: Referer: http://web.mac.com/atarwacki/iWeb/Simply%20Strategic%20Show/Podcast/Podcast.html
[9/19/2006 11:57:35 AM] HTTP0: NSPlayer/10.0.0.3646Host: web.mac.com
[9/19/2006 11:57:35 AM] HTTP0: Accept-Encoding: gzip
[9/19/2006 11:57:35 AM] HTTP0: Transferring data from http://web.mac.com/atarwacki/iWeb/Simply%20Strategic%20Show/Podcast/Podcast_files/Simply%20Strategic%20Week%2028.mp3.
[9/19/2006 11:57:35 AM] HTTP0: HTTP/1.0 401 Unauthorized
[9/19/2006 11:57:35 AM] HTTP0: Date: Tue, 19 Sep 2006 15:56:37 GMT
[9/19/2006 11:57:35 AM] HTTP0: Content-Length: 26
[9/19/2006 11:57:35 AM] HTTP0: Content-Type: text/plain
[9/19/2006 11:57:35 AM] HTTP0: x-responding-server: davhp17
[9/19/2006 11:57:35 AM] HTTP0: Server: AppleDotMacServer
[9/19/2006 11:57:36 AM] HTTP0: WWW-Authenticate: Basic realm="idisk.mac.com"
[9/19/2006 11:57:36 AM] HTTP0: WWW-Authenticate: Digest realm="idisk.mac.com", qop="auth", nonce="ebfbed81ec4ce562ca2fd440bfbdf3cd", stale="false", opaque="ab3b82f9fc8cad4a01e50972d1843b90"
[9/19/2006 11:57:36 AM] HTTP0: Via: 1.1 hpcache05 (NetCache NetApp/6.0.3)
[9/19/2006 11:57:36 AM] HTTP0: 100% of 26 bytes of http://web.mac.com/atarwacki/iWeb/Simply%20Strategic%20Show/Podcast/Podcast_files/Simply%20Strategic%20Week%2028.mp3.
[9/19/2006 11:57:36 AM] HTTP0: Download complete. Status: 401 Unauthorized.
[9/19/2006 12:07:07 PM] HTTP0: Looking up host www.gccwired.com...
[9/19/2006 12:07:08 PM] HTTP0: Connecting to host www.gccwired.com...
[9/19/2006 12:07:09 PM] HTTP0: Host www.gccwired.com connected. Waiting for http://www.gccwired.com/podcast/audio_files/MWA060917.mp3.
[9/19/2006 12:07:09 PM] HTTP0: GET /podcast/audio_files/MWA060917.mp3 HTTP/1.0
[9/19/2006 12:07:09 PM] HTTP0: Accept: *.*, */*
[9/19/2006 12:07:09 PM] HTTP0: Accept-Language: en-us
[9/19/2006 12:07:09 PM] HTTP0: Referer: http://www.gccwired.com/listTemplate2.asp?pageID=63
[9/19/2006 12:07:09 PM] HTTP0: NSPlayer/10.0.0.3646Host: www.gccwired.com
[9/19/2006 12:07:09 PM] HTTP0: Accept-Encoding: gzip
[9/19/2006 12:07:09 PM] HTTP0: Cookie: __utma=207751044.2140217017.1150543808.1158619714.1158620019.21; __utmz=207751044.1158620019.21.14.utmccn=(referral)|utmcsr=xmaveric.com|utmcct=/gcc/|utmcmd=referral
[9/19/2006 12:07:09 PM] HTTP0: Transferring data from http://www.gccwired.com/podcast/audio_files/MWA060917.mp3.
[9/19/2006 12:07:09 PM] HTTP0: HTTP/1.1 400 Bad Request
[9/19/2006 12:07:09 PM] HTTP0: Content-Type: text/html
[9/19/2006 12:07:09 PM] HTTP0: Date: Tue, 19 Sep 2006 16:06:11 GMT
[9/19/2006 12:07:09 PM] HTTP0: Connection: close
[9/19/2006 12:07:09 PM] HTTP0: Content-Length: 42
[9/19/2006 12:07:09 PM] HTTP0: 100% of 42 bytes of http://www.gccwired.com/podcast/audio_files/MWA060917.mp3.
[9/19/2006 12:07:09 PM] HTTP0: Download complete. Status: 400 Bad Request.



Any help would be greatly appreciated!
Joshua Gregory 09/19/2006 12:18 pm
Also, I have tried this from two separate computers in different locations.

If I right-click save-as in Internet Explorer, the files download fine.
Oleg Chernavin 09/20/2006 05:34 am
You should enter username/password for the site in the Project Properties dialog - Password section.

Best regards,
Oleg Chernavin
MP Staff
Joshua Gregory 09/20/2006 06:48 am
> You should enter username/password for the site in the Project Properties dialog - Password section.
>
> Best regards,
> Oleg Chernavin
> MP Staff

But...there is no password required to download the file, I just browse to the site, and download it. Like I said, it works fine in a normal browser.
Oleg Chernavin 09/20/2006 07:19 am
Please try to check the NTLM box in the Options dialog - Proxy section?

Oleg.
Joshua Gregory 09/20/2006 08:48 am
> Please try to check the NTLM box in the Options dialog - Proxy section?
>
> Oleg.

I believe this fixed it! I will do more testing to make sure, but it looks good for now. Thank you!
Oleg Chernavin 09/20/2006 08:50 am
You are welcome!

Oleg.