Possible "speed" bug in 3.9. A regression?

Author Message
Free Beta Tester 08/28/2005 02:31 pm
It seems to me that there is a regression in 3.9sr1.

In 3.7, there was a bug where the speed limit couldn`t be set higher than 37628 kb/s (something like that). I discussed with Oleg about this and was patched and then eventually fixed in 3.8.

But now in 3.9, a similar bug creeps up again. Using 3.9 Enterprise, I can`t get the speed to go past 50 kb/s from Motogp.com`s Real stream. What is worse is that 3.9 Pro hits the limits at 19 kb/s! So I decided to remove 3.9 and put 3.8 back on, and I was able to d/l full speed allowable by the website (over 120 kb/s). I don`t think this has to do with the website as 3.8 works with the website fine. Only affects 3.9, not 3.8, so I think it`s a regression.

Oleg, can you check in to this. I`m quite sure there`s a bug somewhere. And if you do find it fix it, can you kindly email me the patch like you did last time too?
Free Beta Tester 08/28/2005 02:37 pm
I also want to add that in 3.1 and 3.5, I did NOT see this similar speed bug.
Oleg Chernavin 08/30/2005 07:05 am
Do you mean that this happens even when you set Full speed on the toolbar?

Best regards,
Oleg Chernavin
MP Staff
Free Beta Tester 08/31/2005 05:22 am
> Do you mean that this happens even when you set Full speed on the toolbar?
>
> Best regards,
> Oleg Chernavin
> MP Staff

This happens when I define a particular speed setting to be over 50 kb/s. For example, if I define a setting to be 90 kb/s (and I go to select this setting from the toolbar, the only place for me to select), then max speed is only 50 kb/s.

However, I have no problem if the speed setting is set at under 50 kb/s. Eg, if I set the speed of a setting to be 30 kb/s and I select this setting in the toolbar, then I will get to d/l at 30 kb/s.

Even when I set the speed to "unlimited", I still hit the 50 kb/s barrier.
Oleg Chernavin 09/02/2005 02:38 pm
Can you please give me a link to a sample streaming file, so I could reproduce this (compare 3.8 and 3.9 versions)?

Thank you!

Oleg.
Free Beta Tester 09/05/2005 04:53 am
Hi Oleg,

The site is Motogp.com. The error occur when I tried to download one of their Real video file. But unfortunately, the site is a subscription-fee based site, so I can`t give out my password. So I`m stuck here.

(But if you watch motoGP races, you might as well subscribe to this site. It`s 25 euros/yr and well worth it.)
Oleg Chernavin 09/05/2005 01:32 pm
Well, I do not watch races. But you can write me directly to support@metaproducts.com. The password will be used strictly for testing purposes.

Oleg,
Free Beta Tester 09/08/2005 11:02 pm
> Well, I do not watch races. But you can write me directly to support@metaproducts.com. The password will be used strictly for testing purposes.
>
> Oleg,

Any news on this yet Oleg? Were you able to login?
Oleg Chernavin 09/09/2005 02:11 pm
I haven`t received any E-mail from you yet. Can I E-mail you myself using the address you used in the forum?

Oleg.
Free Beta Tester 09/10/2005 01:07 pm
> I haven`t received any E-mail from you yet. Can I E-mail you myself using the address you used in the forum?
>
> Oleg.

That was weird. I emailed my username and password to support@metaproducts.com, and thought you had it all this time. OK I will email you again.
Free Beta Tester 09/10/2005 01:13 pm
Oleg,
I just checked my email and I have certainly emailed my password to support@metaproducts.com earlier, and you must have received it because I didn`t get any bounced message.

Anyway, since then I changed my password because you said you didn`t receive the email and I fear I might have emailed to some alien, but I checked and I did email it to support@metaproducts.com.

So now to be absolutely clear, where do you want me to email you? support@metaproducts.com again?
Oleg Chernavin 09/10/2005 01:15 pm
Our support didn`t send me any messages. Can I E-mail you myself? This can be faster.

Oleg.
Free Beta Tester 09/14/2005 01:01 pm
> Our support didn`t send me any messages. Can I E-mail you myself? This can be faster.
>
> Oleg.

Yes please email me directly.
Oleg Chernavin 09/15/2005 04:18 am
OK. Just E-mailed you.

Oleg.
Free Beta Tester 09/17/2005 10:35 am
> OK. Just E-mailed you.
>
> Oleg.


I just replied to your email with my username and password too
Oleg Chernavin 09/19/2005 04:22 am
Yes, I received it. Thank you! I will work on it today.

Oleg.