Font size problem with 2.4 version

Author Message
PTmax 08/30/2007 10:07 am
Hello to all,

I've recently downloaded the new (2.4) version for testing. I discovered a major discomfort that didn't appear on any of the previous versions. The problem is that the text of the "time scale" and the "speed scale" legends at any Diagram Window is pretty tiny, that makes it impossible to make out, and furthermore the size of the text doesn't resize as you resize the whole window, it stays the same no matter how big the diagram gets.
To prove what I'm saying, and for you to better understand the problem, I give you some screenshots I have taken with various sizes of the window.

http://i118.photobucket.com/albums/o81/ptmax13/Untitled-1.jpg
http://i118.photobucket.com/albums/o81/ptmax13/Untitled-2.jpg
http://i118.photobucket.com/albums/o81/ptmax13/Untitled-3.jpg

Is it my system's problem? Do I have a font missing? Is this a bug?
I await for your response,
thanks for your time...

P.S.: btw, no BSODs till now, and no other bugs known to me... keep up the good work...
Andrey 09/03/2007 06:53 pm
Hello, PTmax,

Thank you for your letter,

> I've recently downloaded the new (2.4) version for testing. I discovered a major discomfort that didn't appear on any of the previous versions. The problem is that the text of the "time scale" and the "speed scale" legends at any Diagram Window is pretty tiny, that makes it impossible to make out, and furthermore the size of the text doesn't resize as you resize the whole window, it stays the same no matter how big the diagram gets.
> ...
> Is it my system's problem? Do I have a font missing? Is this a bug?
> I await for your response,
> thanks for your time...

It seems that you really have something special with your system.
Do you have font named 'Small Fonts' in your %windir%\Fonts directory?

> P.S.: btw, no BSODs till now, and no other bugs known to me... keep up the good work...

Thank you!

Best regards,
Andrey Zotov
MP Staff
PTmax 09/03/2007 07:23 pm
Hello,

I have this font...
http://i118.photobucket.com/albums/o81/ptmax13/untitled.jpg

Is this really a font problem? I don't remember messing around with Fonts and I know this is a standart windows font. If NAD uses a font that I don't have then please tell me...
PTmax 09/26/2007 02:07 pm
hello!!!!????
Andrey 09/26/2007 04:46 pm
Hello, PTmax,

Please, check your email. I've sent you a custom build.
Hope it will solve the problem.

Thank you!

Best regards,
Andrey Zotov
MP Staff
fivad 11/13/2007 12:38 am
> Hello, PTmax,
>
> Please, check your email. I've sent you a custom build.
> Hope it will solve the problem.
>
> Thank you!
>
> Best regards,
> Andrey Zotov
> MP Staff

Hello Andrey,

I have the same problem as PTmax, could you please send me the custom build, too?
Since he didn't come back in the topic, I assume that it's working for him.

Thanks
Alexander 11/13/2007 03:36 am
Fivad,

Thank you for writing us.
Please test the version: http://www.metaproducts.com/download/betas/nadsetup.exe
and write us about the result. Thank you!

Best regards,
Alexander Bednyakov
MP Staff
PTmax 11/13/2007 04:19 am
Actually, I send an email back to Andrey saying that the custom build doesn't work either... but I didin't get an answer...
The problem still exists...
Andrey 11/14/2007 03:45 am
Hello,

The scale labels dynamic font size feature is still under development. It should help in your cases.
Please download and try the updated build:
http://www.metaproducts.com/download/betas/nadsetup.exe

Try resizing diagram window in case of unreadable font.

Thank you for your feedback!

Best regards,
Andrey
MP Staff
fivad 11/15/2007 03:06 am
Thanks guys for the help.
I downloaded and installed the beta with no change regarding the font problem.
I tried I think I found a (funny) way out of this
fivad 11/15/2007 03:18 am
Sorry, for the previous message, I press enter accidentally before I finish...
Here's the good one:

Thanks guys for the help.

I downloaded and installed the beta with no change regarding the font problem.

However, I have some good news for you PTMax!

As was playing around I discovered that the problem seems to happen only with the diagram labeled "Diagram window". If you go to settings-->diagrams and disable it the "Diagram window" and then create a new diagram and then go to properties and assign the type "diagram window" the problem is solved.
Funny thing is that if you change ie the "graph in the tray" diagram type to "graph in the window" is also ok.
PTmax 11/15/2007 07:17 am
nope... this solution doesn't work with my system...
still not getting it...
I 've installed NAD in many systems and all of them are having the same problem... I still wonder why are just the two of us who have reported this...
Andrey 11/16/2007 01:38 pm
Hello,

Could you please send me screenshots with diagram resized to nearly screen size?
Also please try switching off interpolation:
Diagram Properties -> Appearance -> Interpolation

Thank you!

Best regards,
Andrey
MP Staff
John 12/22/2007 06:52 pm
> Hello,
>
> Could you please send me screenshots with diagram resized to nearly screen size?
> Also please try switching off interpolation:
> Diagram Properties -> Appearance -> Interpolation
>
> Thank you!
>
> Best regards,
> Andrey
> MP Staff


Hi Andrey,
I've installed NAD v2.4.339 and having the same "small font" problem mentioned by others in this
thread. I tried the solution suggested by 'fivad' but it doesn't work for me; I also disabled 'Interpolation'
as you recommended-- Still not working. It's otherwise a great App, but the tiny 'Speed' (and 'Time',
too) font on my large monitor limits its usefulness... I hope it can be fixed.
I have a screen capture that shows the problem but I can't find how to upload it.
Thanks,
John
Alex 12/25/2007 09:15 am
John,

Thank you for writing us.
Could you please try the latest build of Net Activity Diagram?
You can download it from: http://www.metaproducts.com/download/nadsetup2.exe

Best regards,
Alexander Bednyakov
MP Staff
John 12/26/2007 08:42 pm
> John,
>
> Thank you for writing us.
> Could you please try the latest build of Net Activity Diagram?
> You can download it from: http://www.metaproducts.com/download/nadsetup2.exe
>
> Best regards,
> Alexander Bednyakov
> MP Staff

Alexander,

I installed the latest NAD (v2.4.345) and it has restored the 'Speed' and 'Time' font scaling; large NAD windows look great. Unfortunately, the starting size of these fonts is still too small for more normal-sized NAD windows -- please see the screen capture below to see what I'm referring to...

http://i267.photobucket.com/albums/ii319/jaysee02/11b761f7.png

If the minimum 'Speed' font was a little larger (about 1.5X - 2X its present size) it would be much more readable on large monitors.

Thanks for your efforts,
John

Alex 12/27/2007 07:12 am
John,

Could you please test the updated build of NAD we uploaded today?
You can get it here: http://www.metaproducts.com/download/nadsetup2.exe

Thanks,
Alexander
John 12/27/2007 07:23 pm
> John,
>
> Could you please test the updated build of NAD we uploaded today?
> You can get it here: http://www.metaproducts.com/download/nadsetup2.exe
>
> Thanks,
> Alexander
>


Alexander,

NAD v2.4.346 appears to scale everything perfectly. Big window, small window -- it's all readable even on a high-resolution monitor. Thanks again for your quick response!

One additional question: If I select 'View Statistics' > 'WiFi Signal Strength' > 'View Graph', shouldn't there be a plot of WiFi strength versus time? Right now, NAD seems to plot only throughput data for Statistics regardless of which diagram is selected.

Thanks,
John
Alex 12/28/2007 01:42 am
John,

NAD shows throughput data only in the Statistics dialog.
Please feel free to contact me if you have any further question.

Sincerely,
Alexander